Cant open elf file in linux Jetson nano


I have problem when i deployed yolo detector to jetson nano and when i tried to open the elf file from desktop it saying the following messages:-

Could not display objectdetector.elf
There is no application installed for shared libraries files

Thanks for reading


For a TLT file, you should be able to deploy it with the steps mentioned in this tutorial:


Dear AastaLLL

I have already deployed the trained detector by Matlab using ARM system and i can find the generated code with elf file in folders of linux from Desktop however when i tried open it by mouse does not supported to be opened and gives messages as i stated earleir. Take in consideration when i generated the code to jetson nano from Matlab i got successful message of deployment and just now i want to run it to test the deployed detector

when i run the file using $./******.elf file from terminal i got the following messages:-

./yolo2detectobject.elf ls :cannot access '/dev/video*:No such file or directory
usupported camera resolution.
Please select of the following supported resolutions[

infact i am using raspi camera v1 and i am ordering now raspi camera v2 which supports nano

1- Do i have to download speciall tool software to run it from desktop?

2- when i run from terminal and i got message Is that meaning now just issue from camera and i can do running the elf file from terminal

Kindly I am looking for your support


Suppose this is duplicate to the topic 1072427.

Please let me know if you have further question.