Can't read CAN device

Hi
I’ve got a SICK IMU which I want to connect via CAN (D-SUB) to the NVIDIA Jetson AGX Xavier.
I’ve used modprobe for can, can-dev, can-raw and mttcan. Then I set up with the bitrate of the IMU und activate can0.

But if I use candump/cansniffer I don’t get any data.

To test the IMU I used a PEAK USB adapter and pcanview. It worked, when I set the right CAN clock to 2000000.
I’ve read that the Jetson has set 500000, and I tried to change:

https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/hw_setup_jetson_can.html#

But I can’t find where to change.

hello gianluca.podann,

you may enable the CAN and configure the CAN interface settings.
for example,
$ ip link set can0 type can bitrate 500000 dbitrate 2000000 berr-reporting on fd on
$ ip link set up can0

thx for help.
I enabled CAN and used your example with my settings, but it doesn’t work.
Does dbitrate mean the clockrate?

hello gianluca.podann,

there’s some known issue to communicate with other devices.
could you please have a try to configure bitrate artificially high (i.e. 3-Mbps setting for 1-Mbps desired) for testing,

it’s bitrate configurations for the dsample-point. it used by CAN_FD interface type.
thanks

With bitrate 3000000 I get: Invalid argument