Can't run apt update in deepstream:6.4-samples-multiarch

I am trying to install the Python bindings inside the DeepStream 6.4 container.
I started the container with:

docker run -it nvcr.io/nvidia/deepstream:6.4-samples-multiarch bash

Inside the container, I run:

apt update

I get the following error:

root@072732663f4c:/opt/nvidia/deepstream/deepstream-6.4# apt update
Get:1 http://archive.ubuntu.com/ubuntu jammy InRelease [270 kB]
Get:2 http://security.ubuntu.com/ubuntu jammy-security InRelease [110 kB]    
Get:3 https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2204/x86_64  InRelease [1581 B]
Get:4 http://archive.ubuntu.com/ubuntu jammy-updates InRelease [119 kB]                            
Get:5 http://archive.ubuntu.com/ubuntu jammy-backports InRelease [109 kB]
Get:6 https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2204/x86_64  Packages [634 kB]
Get:7 http://security.ubuntu.com/ubuntu jammy-security/main amd64 Packages [1326 kB]
Get:8 http://security.ubuntu.com/ubuntu jammy-security/multiverse amd64 Packages [44.0 kB]
Get:9 http://security.ubuntu.com/ubuntu jammy-security/restricted amd64 Packages [1572 kB]
Get:10 http://security.ubuntu.com/ubuntu jammy-security/universe amd64 Packages [1046 kB]
Get:11 http://archive.ubuntu.com/ubuntu jammy/main amd64 Packages [1792 kB]     
Get:12 http://archive.ubuntu.com/ubuntu jammy/universe amd64 Packages [17.5 MB]            
Get:13 http://archive.ubuntu.com/ubuntu jammy/restricted amd64 Packages [164 kB]
Get:14 http://archive.ubuntu.com/ubuntu jammy/multiverse amd64 Packages [266 kB]
Get:15 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 Packages [1305 kB]
Get:16 http://archive.ubuntu.com/ubuntu jammy-updates/multiverse amd64 Packages [49.8 kB]
Get:17 http://archive.ubuntu.com/ubuntu jammy-updates/restricted amd64 Packages [1602 kB]
Get:18 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 Packages [1599 kB]
Get:19 http://archive.ubuntu.com/ubuntu jammy-backports/main amd64 Packages [50.4 kB]
Get:20 http://archive.ubuntu.com/ubuntu jammy-backports/universe amd64 Packages [28.1 kB]
Fetched 29.6 MB in 2s (18.5 MB/s)                                 
Reading package lists... Done
E: Problem executing scripts APT::Update::Post-Invoke 'rm -f /var/cache/apt/archives/*.deb /var/cache/apt/archives/partial/*.deb /var/cache/apt/*.bin || true'
E: Sub-process returned an error code

As a consequence, I can’t complete even the first step of the tutorial https://github.com/NVIDIA-AI-IOT/deepstream_python_apps/tree/202743531730e1393a9b7df98af5b3bcf38fdcdc/bindings which is a simple apt update followed by an apt install.

EDIT: if you run the apt update and then run the apt install for 3 times, you’ll manage to install all the packages.

I realized I needed to start the image using docker run -it --privileged nvcr.io/nvidia/deepstream:6.4-samples-multiarch bash

However, I am still not sure how to install the python bindings during a docker build since the --privileged option is not available for the docker build command. How can I install the python bindings during the docker build?

I am okay using a multi-stage docker image. I am trying to run this:

FROM nvcr.io/nvidia/deepstream:6.4-gc-triton-devel as builder
RUN bash /opt/nvidia/deepstream/deepstream-6.4/user_deepstream_python_apps_install.sh -b

But I get the error:

Step 1/46 : FROM nvcr.io/nvidia/deepstream:6.4-gc-triton-devel as builder
 ---> b8c3bc4f902c
Step 2/46 : RUN bash /opt/nvidia/deepstream/deepstream-6.4/user_deepstream_python_apps_install.sh -b
 ---> Running in a6547c500af7
####################################
Downloading necessary pre-requisites
####################################
Hit:1 http://archive.ubuntu.com/ubuntu jammy InRelease
Get:2 http://security.ubuntu.com/ubuntu jammy-security InRelease [110 kB]      
Get:3 http://archive.ubuntu.com/ubuntu jammy-updates InRelease [119 kB]        
Get:4 https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2204/x86_64  InRelease [1581 B]
Get:5 http://archive.ubuntu.com/ubuntu jammy-backports InRelease [109 kB]      
Get:6 https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2204/x86_64  Packages [637 kB]
Get:7 http://security.ubuntu.com/ubuntu jammy-security/restricted amd64 Packages [1572 kB]
Hit:8 https://librealsense.intel.com/Debian/apt-repo jammy InRelease
Get:9 http://security.ubuntu.com/ubuntu jammy-security/universe amd64 Packages [1046 kB]
Get:10 http://security.ubuntu.com/ubuntu jammy-security/main amd64 Packages [1326 kB]
Get:11 http://archive.ubuntu.com/ubuntu jammy-updates/restricted amd64 Packages [1602 kB]
Get:12 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 Packages [1599 kB]
Get:13 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 Packages [1305 kB]
Get:14 http://archive.ubuntu.com/ubuntu jammy-backports/main amd64 Packages [50.4 kB]
Get:15 http://archive.ubuntu.com/ubuntu jammy-backports/universe amd64 Packages [28.1 kB]
Fetched 9505 kB in 1s (11.0 MB/s)                            
Reading package lists... Done
W: https://librealsense.intel.com/Debian/apt-repo/dists/jammy/InRelease: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION section in apt-key(8) for details.
E: Problem executing scripts APT::Update::Post-Invoke-Success '/usr/bin/test -e /usr/share/dbus-1/system-services/org.freedesktop.PackageKit.service && /usr/bin/test -S /var/run/dbus/system_bus_socket && /usr/bin/gdbus call --system --dest org.freedesktop.PackageKit --object-path /org/freedesktop/PackageKit --timeout 4 --method org.freedesktop.PackageKit.StateHasChanged cache-update > /dev/null; /bin/echo > /dev/null'
E: Sub-process returned an error code
E: Problem executing scripts APT::Update::Post-Invoke 'rm -f /var/cache/apt/archives/*.deb /var/cache/apt/archives/partial/*.deb /var/cache/apt/*.bin || true'
E: Sub-process returned an error code
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
  libaacs0 libavfilter7 libavformat58 libbdplus0 libblas3 libbluray2
  libgfortran5 liblapack3 libmysofa1 libnorm1 libpgm-5.3-0 libpocketsphinx3
  libpostproc55 librubberband2 libsphinxbase3 libssh-gcrypt-4 libswscale5
  libudfread0 libvidstab1.1 libzimg2 libzmq5 pocketsphinx-en-us
Suggested packages:
  libbluray-bdj
The following NEW packages will be installed:
  gstreamer1.0-libav libaacs0 libavfilter7 libavformat58 libbdplus0 libblas3
  libbluray2 libgfortran5 liblapack3 libmysofa1 libnorm1 libpgm-5.3-0
  libpocketsphinx3 libpostproc55 librubberband2 libsphinxbase3 libssh-gcrypt-4
  libswscale5 libudfread0 libvidstab1.1 libzimg2 libzmq5 pocketsphinx-en-us
0 upgraded, 23 newly installed, 0 to remove and 113 not upgraded.
Need to get 37.1 MB of archives.
After this operation, 64.1 MB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libudfread0 amd64 1.1.2-1 [16.2 kB]
Get:2 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libbluray2 amd64 1:1.3.1-1 [159 kB]
Get:3 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 libssh-gcrypt-4 amd64 0.9.6-2ubuntu0.22.04.1 [222 kB]
Get:4 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libnorm1 amd64 1.5.9+dfsg-2 [221 kB]
Get:5 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libpgm-5.3-0 amd64 5.3.128~dfsg-2 [161 kB]
Get:6 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libzmq5 amd64 4.3.4-2 [256 kB]
Get:7 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 libavformat58 amd64 7:4.4.2-0ubuntu0.22.04.1 [1103 kB]
Get:8 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libmysofa1 amd64 1.2.1~dfsg0-1 [1157 kB]
Get:9 http://archive.ubuntu.com/ubuntu jammy/main amd64 libblas3 amd64 3.10.0-2ubuntu1 [228 kB]
Get:10 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 libgfortran5 amd64 12.3.0-1ubuntu1~22.04 [879 kB]
Get:11 http://archive.ubuntu.com/ubuntu jammy/main amd64 liblapack3 amd64 3.10.0-2ubuntu1 [2504 kB]
Get:12 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libsphinxbase3 amd64 0.8+5prealpha+1-13build1 [126 kB]
Get:13 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libpocketsphinx3 amd64 0.8.0+real5prealpha+1-14ubuntu1 [132 kB]
Get:14 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 libpostproc55 amd64 7:4.4.2-0ubuntu0.22.04.1 [60.1 kB]
Get:15 http://archive.ubuntu.com/ubuntu jammy/universe amd64 librubberband2 amd64 2.0.0-2 [90.0 kB]
Get:16 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 libswscale5 amd64 7:4.4.2-0ubuntu0.22.04.1 [180 kB]
Get:17 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libvidstab1.1 amd64 1.1.0-2 [35.0 kB]
Get:18 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libzimg2 amd64 3.0.3+ds1-1 [241 kB]
Get:19 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 libavfilter7 amd64 7:4.4.2-0ubuntu0.22.04.1 [1496 kB]
Get:20 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 gstreamer1.0-libav amd64 1.20.3-0ubuntu1 [103 kB]
Get:21 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libaacs0 amd64 0.11.1-1 [64.1 kB]
Get:22 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libbdplus0 amd64 0.2.0-1 [52.2 kB]
Get:23 http://archive.ubuntu.com/ubuntu jammy/universe amd64 pocketsphinx-en-us all 0.8.0+real5prealpha+1-14ubuntu1 [27.6 MB]
Fetched 37.1 MB in 0s (79.8 MB/s)            
Selecting previously unselected package libudfread0:amd64.
(Reading database ... 74559 files and directories currently installed.)
Preparing to unpack .../00-libudfread0_1.1.2-1_amd64.deb ...
Unpacking libudfread0:amd64 (1.1.2-1) ...
Selecting previously unselected package libbluray2:amd64.
Preparing to unpack .../01-libbluray2_1%3a1.3.1-1_amd64.deb ...
Unpacking libbluray2:amd64 (1:1.3.1-1) ...
Selecting previously unselected package libssh-gcrypt-4:amd64.
Preparing to unpack .../02-libssh-gcrypt-4_0.9.6-2ubuntu0.22.04.1_amd64.deb ...
Unpacking libssh-gcrypt-4:amd64 (0.9.6-2ubuntu0.22.04.1) ...
Selecting previously unselected package libnorm1:amd64.
Preparing to unpack .../03-libnorm1_1.5.9+dfsg-2_amd64.deb ...
Unpacking libnorm1:amd64 (1.5.9+dfsg-2) ...
Selecting previously unselected package libpgm-5.3-0:amd64.
Preparing to unpack .../04-libpgm-5.3-0_5.3.128~dfsg-2_amd64.deb ...
Unpacking libpgm-5.3-0:amd64 (5.3.128~dfsg-2) ...
Selecting previously unselected package libzmq5:amd64.
Preparing to unpack .../05-libzmq5_4.3.4-2_amd64.deb ...
Unpacking libzmq5:amd64 (4.3.4-2) ...
Selecting previously unselected package libavformat58:amd64.
Preparing to unpack .../06-libavformat58_7%3a4.4.2-0ubuntu0.22.04.1_amd64.deb ...
Unpacking libavformat58:amd64 (7:4.4.2-0ubuntu0.22.04.1) ...
Selecting previously unselected package libmysofa1:amd64.
Preparing to unpack .../07-libmysofa1_1.2.1~dfsg0-1_amd64.deb ...
Unpacking libmysofa1:amd64 (1.2.1~dfsg0-1) ...
Selecting previously unselected package libblas3:amd64.
Preparing to unpack .../08-libblas3_3.10.0-2ubuntu1_amd64.deb ...
Unpacking libblas3:amd64 (3.10.0-2ubuntu1) ...
Selecting previously unselected package libgfortran5:amd64.
Preparing to unpack .../09-libgfortran5_12.3.0-1ubuntu1~22.04_amd64.deb ...
Unpacking libgfortran5:amd64 (12.3.0-1ubuntu1~22.04) ...
Selecting previously unselected package liblapack3:amd64.
Preparing to unpack .../10-liblapack3_3.10.0-2ubuntu1_amd64.deb ...
Unpacking liblapack3:amd64 (3.10.0-2ubuntu1) ...
Selecting previously unselected package libsphinxbase3:amd64.
Preparing to unpack .../11-libsphinxbase3_0.8+5prealpha+1-13build1_amd64.deb ...
Unpacking libsphinxbase3:amd64 (0.8+5prealpha+1-13build1) ...
Selecting previously unselected package libpocketsphinx3:amd64.
Preparing to unpack .../12-libpocketsphinx3_0.8.0+real5prealpha+1-14ubuntu1_amd64.deb ...
Unpacking libpocketsphinx3:amd64 (0.8.0+real5prealpha+1-14ubuntu1) ...
Selecting previously unselected package libpostproc55:amd64.
Preparing to unpack .../13-libpostproc55_7%3a4.4.2-0ubuntu0.22.04.1_amd64.deb ...
Unpacking libpostproc55:amd64 (7:4.4.2-0ubuntu0.22.04.1) ...
Selecting previously unselected package librubberband2:amd64.
Preparing to unpack .../14-librubberband2_2.0.0-2_amd64.deb ...
Unpacking librubberband2:amd64 (2.0.0-2) ...
Selecting previously unselected package libswscale5:amd64.
Preparing to unpack .../15-libswscale5_7%3a4.4.2-0ubuntu0.22.04.1_amd64.deb ...
Unpacking libswscale5:amd64 (7:4.4.2-0ubuntu0.22.04.1) ...
Selecting previously unselected package libvidstab1.1:amd64.
Preparing to unpack .../16-libvidstab1.1_1.1.0-2_amd64.deb ...
Unpacking libvidstab1.1:amd64 (1.1.0-2) ...
Selecting previously unselected package libzimg2:amd64.
Preparing to unpack .../17-libzimg2_3.0.3+ds1-1_amd64.deb ...
Unpacking libzimg2:amd64 (3.0.3+ds1-1) ...
Selecting previously unselected package libavfilter7:amd64.
Preparing to unpack .../18-libavfilter7_7%3a4.4.2-0ubuntu0.22.04.1_amd64.deb ...
Unpacking libavfilter7:amd64 (7:4.4.2-0ubuntu0.22.04.1) ...
Selecting previously unselected package gstreamer1.0-libav:amd64.
Preparing to unpack .../19-gstreamer1.0-libav_1.20.3-0ubuntu1_amd64.deb ...
Unpacking gstreamer1.0-libav:amd64 (1.20.3-0ubuntu1) ...
Selecting previously unselected package libaacs0:amd64.
Preparing to unpack .../20-libaacs0_0.11.1-1_amd64.deb ...
Unpacking libaacs0:amd64 (0.11.1-1) ...
Selecting previously unselected package libbdplus0:amd64.
Preparing to unpack .../21-libbdplus0_0.2.0-1_amd64.deb ...
Unpacking libbdplus0:amd64 (0.2.0-1) ...
Selecting previously unselected package pocketsphinx-en-us.
Preparing to unpack .../22-pocketsphinx-en-us_0.8.0+real5prealpha+1-14ubuntu1_all.deb ...
Unpacking pocketsphinx-en-us (0.8.0+real5prealpha+1-14ubuntu1) ...
dpkg: error: error executing hook 'if { test "$DPKG_HOOK_ACTION" = add-architecture || test "$DPKG_HOOK_ACTION" = remove-architecture; } && test -x /usr/share/pkg-config-dpkghook; then /usr/share/pkg-config-dpkghook update; fi', exit code 32512
E: Sub-process /usr/bin/dpkg returned an error code (2)
E: Problem executing scripts DPkg::Post-Invoke '/usr/bin/test -e /usr/share/dbus-1/system-services/org.freedesktop.PackageKit.service && /usr/bin/test -S /var/run/dbus/system_bus_socket && /usr/bin/gdbus call --system --dest org.freedesktop.PackageKit --object-path /org/freedesktop/PackageKit --timeout 4 --method org.freedesktop.PackageKit.StateHasChanged cache-update > /dev/null; /bin/echo > /dev/null'
E: Sub-process returned an error code
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
  libgstreamer-plugins-bad1.0-0
Suggested packages:
  frei0r-plugins
The following NEW packages will be installed:
  libavcodec-dev libavformat-dev libavutil-dev libde265-dev libswresample-dev
The following packages will be upgraded:
  gstreamer1.0-plugins-bad libgstreamer-plugins-bad1.0-0
2 upgraded, 5 newly installed, 13 reinstalled, 0 to remove and 111 not upgraded.
23 not fully installed or removed.
Need to get 22.6 MB of archives.
After this operation, 29.7 MB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 gstreamer1.0-plugins-bad amd64 1.20.3-0ubuntu1.1 [2602 kB]
Get:2 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 gstreamer1.0-plugins-good amd64 1.20.3-0ubuntu1.1 [2008 kB]
Get:3 http://archive.ubuntu.com/ubuntu jammy/universe amd64 gstreamer1.0-plugins-ugly amd64 1.20.1-1 [225 kB]
Get:4 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 libgstreamer-plugins-bad1.0-0 amd64 1.20.3-0ubuntu1.1 [489 kB]
Get:5 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 libavutil-dev amd64 7:4.4.2-0ubuntu0.22.04.1 [427 kB]
Get:6 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 libswresample-dev amd64 7:4.4.2-0ubuntu0.22.04.1 [78.0 kB]
Get:7 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 libavcodec-dev amd64 7:4.4.2-0ubuntu0.22.04.1 [6221 kB]
Get:8 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 libavcodec58 amd64 7:4.4.2-0ubuntu0.22.04.1 [5567 kB]
Get:9 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 libavformat-dev amd64 7:4.4.2-0ubuntu0.22.04.1 [1347 kB]
Get:10 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 libavutil56 amd64 7:4.4.2-0ubuntu0.22.04.1 [290 kB]
Get:11 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libde265-0 amd64 1.0.8-1 [243 kB]
Get:12 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libde265-dev amd64 1.0.8-1 [11.8 kB]
Get:13 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libmpeg2-4 amd64 0.5.1-9 [50.7 kB]
Get:14 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libmpeg2encpp-2.1-0 amd64 1:2.1.0+debian-6build1 [69.4 kB]
Get:15 http://archive.ubuntu.com/ubuntu jammy/main amd64 libmpg123-0 amd64 1.29.3-1build1 [172 kB]
Get:16 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 libvpx7 amd64 1.11.0-2ubuntu2.2 [1078 kB]
Get:17 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libx264-163 amd64 2:0.163.3060+git5db6aa6-2build1 [591 kB]
Get:18 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libx265-199 amd64 3.5-2 [1170 kB]
Fetched 22.6 MB in 2s (13.3 MB/s)      
E: Internal Error, No file name for libavformat58:amd64
Deleting GStreamer cache
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
autoconf is already the newest version (2.71-2).
automake is already the newest version (1:1.16.5-1.3).
build-essential is already the newest version (12.9ubuntu3).
g++ is already the newest version (4:11.2.0-1ubuntu1).
g++ set to manually installed.
libcairo2-dev is already the newest version (1.16.0-5ubuntu2).
libcairo2-dev set to manually installed.
libtool is already the newest version (2.4.6-15build2).
libtool set to manually installed.
m4 is already the newest version (1.4.18-5ubuntu2).
m4 set to manually installed.
meson is already the newest version (0.61.2-1).
git is already the newest version (1:2.34.1-1ubuntu1.10).
libglib2.0-dev is already the newest version (2.72.4-0ubuntu2.2).
libglib2.0-dev-bin is already the newest version (2.72.4-0ubuntu2.2).
libgstreamer1.0-dev is already the newest version (1.20.3-0ubuntu1).
python3 is already the newest version (3.10.6-1~22.04).
python3-gi is already the newest version (3.42.1-0ubuntu1).
python3-pip is already the newest version (22.0.2+dfsg-1ubuntu0.4).
The following additional packages will be installed:
  cmake-data dh-elpa-helper emacsen-common gobject-introspection
  javascript-common libjs-jquery libjs-sphinxdoc libjs-underscore
  libpython3.10 libpython3.10-dev libpython3.10-minimal libpython3.10-stdlib
  librhash0 libuv1 python3-mako python3-markdown python3-markupsafe
  python3-pygments python3.10 python3.10-minimal
Suggested packages:
  cmake-doc cmake-format apache2 | lighttpd | httpd libgirepository1.0-doc
  python3-beaker python-mako-doc python-markdown-doc python-pygments-doc
  ttf-bitstream-vera python3.10-venv python3.10-doc
The following NEW packages will be installed:
  cmake cmake-data dh-elpa-helper emacsen-common gobject-introspection
  javascript-common libgirepository1.0-dev libjs-jquery libjs-sphinxdoc
  libjs-underscore librhash0 libuv1 python-gi-dev python3-dev python3-gst-1.0
  python3-mako python3-markdown python3-markupsafe python3-pygments
  python3.10-dev
The following packages will be upgraded:
  libpython3.10 libpython3.10-dev libpython3.10-minimal libpython3.10-stdlib
  python3.10 python3.10-minimal
6 upgraded, 20 newly installed, 0 to remove and 107 not upgraded.
23 not fully installed or removed.
Need to get 22.5 MB of archives.
After this operation, 51.7 MB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 libpython3.10-dev amd64 3.10.12-1~22.04.3 [4762 kB]
Get:2 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 libpython3.10 amd64 3.10.12-1~22.04.3 [1948 kB]
Get:3 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 python3.10 amd64 3.10.12-1~22.04.3 [508 kB]
Get:4 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 libpython3.10-stdlib amd64 3.10.12-1~22.04.3 [1848 kB]
Get:5 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 python3.10-minimal amd64 3.10.12-1~22.04.3 [2242 kB]
Get:6 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 libpython3.10-minimal amd64 3.10.12-1~22.04.3 [812 kB]
Get:7 http://archive.ubuntu.com/ubuntu jammy/main amd64 libuv1 amd64 1.43.0-1 [93.1 kB]
Get:8 http://archive.ubuntu.com/ubuntu jammy/main amd64 librhash0 amd64 1.4.2-1ubuntu1 [125 kB]
Get:9 http://archive.ubuntu.com/ubuntu jammy/main amd64 dh-elpa-helper all 2.0.9ubuntu1 [7610 B]
Get:10 http://archive.ubuntu.com/ubuntu jammy/main amd64 emacsen-common all 3.0.4 [14.9 kB]
Get:11 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 cmake-data all 3.22.1-1ubuntu1.22.04.1 [1913 kB]
Get:12 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 cmake amd64 3.22.1-1ubuntu1.22.04.1 [5013 kB]
Get:13 http://archive.ubuntu.com/ubuntu jammy/main amd64 python3-markupsafe amd64 2.0.1-2build1 [12.7 kB]
Get:14 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 python3-mako all 1.1.3+ds1-2ubuntu0.1 [60.5 kB]
Get:15 http://archive.ubuntu.com/ubuntu jammy/main amd64 python3-markdown all 3.3.6-1 [68.5 kB]
Get:16 http://archive.ubuntu.com/ubuntu jammy/main amd64 gobject-introspection amd64 1.72.0-1 [297 kB]
Get:17 http://archive.ubuntu.com/ubuntu jammy/main amd64 javascript-common all 11+nmu1 [5936 B]
Get:18 http://archive.ubuntu.com/ubuntu jammy/main amd64 libgirepository1.0-dev amd64 1.72.0-1 [847 kB]
Get:19 http://archive.ubuntu.com/ubuntu jammy/main amd64 libjs-jquery all 3.6.0+dfsg+~3.5.13-1 [321 kB]
Get:20 http://archive.ubuntu.com/ubuntu jammy/main amd64 libjs-underscore all 1.13.2~dfsg-2 [118 kB]
Get:21 http://archive.ubuntu.com/ubuntu jammy/main amd64 libjs-sphinxdoc all 4.3.2-1 [139 kB]
Get:22 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 python-gi-dev amd64 3.42.1-0ubuntu1 [8508 B]
Get:23 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 python3.10-dev amd64 3.10.12-1~22.04.3 [507 kB]
Get:24 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 python3-dev amd64 3.10.6-1~22.04 [26.0 kB]
Get:25 http://archive.ubuntu.com/ubuntu jammy/universe amd64 python3-gst-1.0 amd64 1.20.1-1 [18.7 kB]
Get:26 http://archive.ubuntu.com/ubuntu jammy/main amd64 python3-pygments all 2.11.2+dfsg-2 [750 kB]
Fetched 22.5 MB in 2s (14.1 MB/s)          
(Reading database ... 74700 files and directories currently installed.)
Preparing to unpack .../00-libpython3.10-dev_3.10.12-1~22.04.3_amd64.deb ...
Unpacking libpython3.10-dev:amd64 (3.10.12-1~22.04.3) over (3.10.12-1~22.04.2) ...
Preparing to unpack .../01-libpython3.10_3.10.12-1~22.04.3_amd64.deb ...
Unpacking libpython3.10:amd64 (3.10.12-1~22.04.3) over (3.10.12-1~22.04.2) ...
Preparing to unpack .../02-python3.10_3.10.12-1~22.04.3_amd64.deb ...
Unpacking python3.10 (3.10.12-1~22.04.3) over (3.10.12-1~22.04.2) ...
Preparing to unpack .../03-libpython3.10-stdlib_3.10.12-1~22.04.3_amd64.deb ...
Unpacking libpython3.10-stdlib:amd64 (3.10.12-1~22.04.3) over (3.10.12-1~22.04.2) ...
Preparing to unpack .../04-python3.10-minimal_3.10.12-1~22.04.3_amd64.deb ...
Unpacking python3.10-minimal (3.10.12-1~22.04.3) over (3.10.12-1~22.04.2) ...
Preparing to unpack .../05-libpython3.10-minimal_3.10.12-1~22.04.3_amd64.deb ...
Unpacking libpython3.10-minimal:amd64 (3.10.12-1~22.04.3) over (3.10.12-1~22.04.2) ...
Selecting previously unselected package libuv1:amd64.
Preparing to unpack .../06-libuv1_1.43.0-1_amd64.deb ...
Unpacking libuv1:amd64 (1.43.0-1) ...
Selecting previously unselected package librhash0:amd64.
Preparing to unpack .../07-librhash0_1.4.2-1ubuntu1_amd64.deb ...
Unpacking librhash0:amd64 (1.4.2-1ubuntu1) ...
Selecting previously unselected package dh-elpa-helper.
Preparing to unpack .../08-dh-elpa-helper_2.0.9ubuntu1_all.deb ...
Unpacking dh-elpa-helper (2.0.9ubuntu1) ...
Selecting previously unselected package emacsen-common.
Preparing to unpack .../09-emacsen-common_3.0.4_all.deb ...
Unpacking emacsen-common (3.0.4) ...
Selecting previously unselected package cmake-data.
Preparing to unpack .../10-cmake-data_3.22.1-1ubuntu1.22.04.1_all.deb ...
Unpacking cmake-data (3.22.1-1ubuntu1.22.04.1) ...
Selecting previously unselected package cmake.
Preparing to unpack .../11-cmake_3.22.1-1ubuntu1.22.04.1_amd64.deb ...
Unpacking cmake (3.22.1-1ubuntu1.22.04.1) ...
Selecting previously unselected package python3-markupsafe.
Preparing to unpack .../12-python3-markupsafe_2.0.1-2build1_amd64.deb ...
Unpacking python3-markupsafe (2.0.1-2build1) ...
Selecting previously unselected package python3-mako.
Preparing to unpack .../13-python3-mako_1.1.3+ds1-2ubuntu0.1_all.deb ...
Unpacking python3-mako (1.1.3+ds1-2ubuntu0.1) ...
Selecting previously unselected package python3-markdown.
Preparing to unpack .../14-python3-markdown_3.3.6-1_all.deb ...
Unpacking python3-markdown (3.3.6-1) ...
Selecting previously unselected package gobject-introspection.
Preparing to unpack .../15-gobject-introspection_1.72.0-1_amd64.deb ...
Unpacking gobject-introspection (1.72.0-1) ...
Selecting previously unselected package javascript-common.
Preparing to unpack .../16-javascript-common_11+nmu1_all.deb ...
Unpacking javascript-common (11+nmu1) ...
Selecting previously unselected package libgirepository1.0-dev:amd64.
Preparing to unpack .../17-libgirepository1.0-dev_1.72.0-1_amd64.deb ...
Unpacking libgirepository1.0-dev:amd64 (1.72.0-1) ...
Selecting previously unselected package libjs-jquery.
Preparing to unpack .../18-libjs-jquery_3.6.0+dfsg+~3.5.13-1_all.deb ...
Unpacking libjs-jquery (3.6.0+dfsg+~3.5.13-1) ...
Selecting previously unselected package libjs-underscore.
Preparing to unpack .../19-libjs-underscore_1.13.2~dfsg-2_all.deb ...
Unpacking libjs-underscore (1.13.2~dfsg-2) ...
Selecting previously unselected package libjs-sphinxdoc.
Preparing to unpack .../20-libjs-sphinxdoc_4.3.2-1_all.deb ...
Unpacking libjs-sphinxdoc (4.3.2-1) ...
Selecting previously unselected package python-gi-dev.
Preparing to unpack .../21-python-gi-dev_3.42.1-0ubuntu1_amd64.deb ...
Unpacking python-gi-dev (3.42.1-0ubuntu1) ...
Selecting previously unselected package python3.10-dev.
Preparing to unpack .../22-python3.10-dev_3.10.12-1~22.04.3_amd64.deb ...
Unpacking python3.10-dev (3.10.12-1~22.04.3) ...
Selecting previously unselected package python3-dev.
Preparing to unpack .../23-python3-dev_3.10.6-1~22.04_amd64.deb ...
Unpacking python3-dev (3.10.6-1~22.04) ...
Selecting previously unselected package python3-gst-1.0.
Preparing to unpack .../24-python3-gst-1.0_1.20.1-1_amd64.deb ...
Unpacking python3-gst-1.0 (1.20.1-1) ...
Selecting previously unselected package python3-pygments.
Preparing to unpack .../25-python3-pygments_2.11.2+dfsg-2_all.deb ...
Unpacking python3-pygments (2.11.2+dfsg-2) ...
dpkg: error: error executing hook 'if { test "$DPKG_HOOK_ACTION" = add-architecture || test "$DPKG_HOOK_ACTION" = remove-architecture; } && test -x /usr/share/pkg-config-dpkghook; then /usr/share/pkg-config-dpkghook update; fi', exit code 32512
E: Sub-process /usr/bin/dpkg returned an error code (2)
E: Problem executing scripts DPkg::Post-Invoke '/usr/bin/test -e /usr/share/dbus-1/system-services/org.freedesktop.PackageKit.service && /usr/bin/test -S /var/run/dbus/system_bus_socket && /usr/bin/gdbus call --system --dest org.freedesktop.PackageKit --object-path /org/freedesktop/PackageKit --timeout 4 --method org.freedesktop.PackageKit.StateHasChanged cache-update > /dev/null; /bin/echo > /dev/null'
E: Sub-process returned an error code
#################################
Default sync branch set to master
#################################
Cloning into 'deepstream_python_apps'...
fatal: unable to access 'https://github.com/NVIDIA-AI-IOT/deepstream_python_apps.git/': getaddrinfo() thread failed to start
deepstream_python_apps clone from branch master FAILED! Exiting...
The command '/bin/sh -c bash /opt/nvidia/deepstream/deepstream-6.4/user_deepstream_python_apps_install.sh -b' returned a non-zero code: 1
Makefile:4: recipe for target 'build' failed
make: *** [build] Error 1

So it looks like even within nvcr.io/nvidia/deepstream:6.4-gc-triton-devel I would need the privileged mode.

Thank you

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.