Can't start X: Failed to initialize DMA.

Hi,

I’m running Gentoo on an amd64 system, and want to run my GT520 card with nvidia drivers.
Kernel version is 3.6.8 vanilla sources, with the following configuration: http://bpaste.net/show/61869/
xorg version is 1.13.0

Building the nvidia kernel module works fine, but when i start X, after validating the metamodes, it fails with “(EE) NVIDIA(0): Failed to initialize DMA.”
I can’t find anything about this error on google, i tried dozens of diffrent kernel configurations and versions.
I even downgraded to nvidia driver version 304.64, but this version only freezes, showing a black screen but no error message.
Here’s a log of Xorg failing to start: http://bpaste.net/show/61870/

Edit: I can’t attach the bugreport-log, as is’t not a picture(?!), i uploaded it: http://btbn.de/files/nvidia-bug-report.log.gz

I see quite a few of these errors in your log file:

Dec  3 13:35:59 Syobon kernel: NVRM: Can't find an IRQ for your NVIDIA card!
Dec  3 13:35:59 Syobon kernel: NVRM: Please check your BIOS settings.
Dec  3 13:35:59 Syobon kernel: NVRM: [Plug & Play OS] should be set to NO
Dec  3 13:35:59 Syobon kernel: NVRM: [Assign IRQ to VGA] should be set to YES 
Dec  3 13:35:59 Syobon kernel: NVRM: The NVIDIA probe routine failed for 1 device(s).
Dec  3 13:35:59 Syobon kernel: NVRM: None of the NVIDIA graphics adapters were initialized!

This looks like a problem either in your kernel or in the system BIOS where interrupts are not getting set up correctly. Which motherboard are you using and what BIOS version does it have?

That seems to be a leftover from when i recompiled the kernel without recompiling the driver(Tested with/without IOMMU support which needs a module recompile). After i recompiled the module these messages stopped and the module loaded fine. But still the same DMA Error.
Even if i disable the indirect memory usage(3GB seemed a bit much on a system with onls 2GB ram), the DMA error stays.

It’s an ASRock G41MH/USB3 with an “up to date” bios 1.10 and an ASUS GT520 low profile card with 1GB vram.

The card works fine with nouveau drivers, but i need vdpau for video decoding.

According to the errors in the log, the GPU is reporting memory errors as soon as it’s initialized, preventing the X driver from starting up correctly. Do you have a different GPU you could try in the same slot to see if it’s a problem with the GPU?

Unfurtunaltely not, I only got my Laptop here.
I used this card for month on Windows and never had any problems.

And now i plugged in my Ubuntu Live Stick, and it shows(with nouveau driver) a lot of corrupted images and artifacts, specialy on animated spots.

So the cards memory broke? Could this be caused by the linux driver? Cause the very first time I started xorg on it, it came up properly, but froze later.
Is there anything i can do to test if the card or its memory realy got corrupted?

I’m not aware of any tools to check your GPU in Linux, but in Windows you should try Video Memory stress Test v1.7 - I won’t give any links, find it in Google.

You can also try running OCCTGPUv0.70.zip but it can easily fry your GPU unless you have proper ventilation.

Hi,
I just saw your post now, have you find a solution ?
I guess this is the same problem as here:
https://devtalk.nvidia.com/default/topic/572278/linux/xorg-does-not-start-with-gt520-and-kernel-3-9-9/
Bye
helmut

Internally Filed bug 1357839 to track this issue

Hey guys, I am not able to find exact Asus GT520 gpu, Is this happening with any other gpu?

Is there any process on this topic ?
The problem still persists and I got the same error with a Zotac H77 ITX Board with onboard GT620.

Good day!

I was struggling of DMA error on Zotac board as well. I managed to fix it today.

Look at my post in different thread: https://devtalk.nvidia.com/default/topic/635955/linux/-nvidia-319-conflict-with-ram-failed-to-initialize-dma-ubuntu-13-10-/post/4162779/#4162779