Xorg does not start with GT520 and kernel 3.9.9

Hello

My just released Gentoo based 64 bit Distribution works fine with kernel 3.9.9 and nvidia 325.08 and most NVidia cards.
But I have two users with the same HW Combo:
Asus GT520 + ASRock H61M/U3S3
and both system do not start X, it ends with:
[ 20.881] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
[ 20.915] (**) NVIDIA(0): DPI set to (100, 100); computed from “DPI” X config option
[ 20.915] (–) Depth 24 pixmap format is 32 bpp
[ 20.915] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[ 20.915] (II) NVIDIA: access.
[ 23.917] (EE) NVIDIA(GPU-0): Failed to initialize DMA.
[ 23.917] (EE) *** Aborting ***

I tried all available version in the gentoo portage ( 304 310 … 325 ) each version shows the same error. The same HW combination works flawlessly with 32bit kernel 3.2 and nvidia 290 driver.

Unfortunately I just lost the the Bug report due to a reboot, I will collect this one tomorrow.

Bye
Helmut

P.S. Which part is responsible for the usage of 3 GB virtual memory ? Can this be reduced ?

And here is the report

Now I tried it with disabling DRM in the kernel and unsetting DMA_SHARED_BUF but the result remains the same. Also disabling IndirectMemoryAccess in the xorg.conf does not help.

Any more hints what I can try ?
nvidia-bug-report.log.gz (59.6 KB)

Hi Guys,

Sorry for the impatience, no ideas what else I can try ?

Bye
Helmut

Internally Filed bug 1357839 to track this issue

Helmut, can you try disabling uvesafb and see if it helps.

From your logs file I see…

[ 0.672286] uvesafb: NVIDIA Corporation, GF108 Board - 1071v101, Chip Rev , OEM: NVIDIA, VBE v3.0
[ 0.725433] uvesafb: VBIOS/hardware doesn’t support DDC transfers
[ 0.725518] uvesafb: no monitor limits have been set, default refresh rate will be used
[ 0.725908] uvesafb: scrolling: redraw

Hey guys, I am not able to find exact Asus GT520 gpu, Is this happening with any other gpu?

Is there any process on this topic ?
The problem still persists and I got the same error with a Zotac H77 ITX Board with onboard GT620.

I am reporting that I was able to fix it in my scenario:

https://devtalk.nvidia.com/default/topic/635955/linux/-nvidia-319-conflict-with-ram-failed-to-initialize-dma-ubuntu-13-10-/post/4162779/#4162779