GeForce driver problem on Centos 6.4 with XEN installed

I am running a Centos 6.4 box with a GeForce 9500 GT video card. I have XEN 4.0 installed on the box too. I recently upgraded the dom0 kernel to 3.10.29-11 and installed the NVIDIA driver version 331.38 and now I cannot get X to start. Once I try to start X the monitor screen goes black and I cannot switch to any virtual terminal. Installation of version 331.38 of the NVIDIA driver completes with no errors.

I’ve tried uninstalling the NVIDIA driver and reinstalling an older version that worked, but this doesn’t help matters now.

Can anyone help me?

This is from the Xorg.0.log file (there really is no “t” in sofware):
[ 29501.243] (EE) NVIDIA(0): Failed to allocate sofware rendering cache surface: out of
[ 29501.243] (EE) NVIDIA(0): memory.
[ 29501.243] (EE) NVIDIA(0): *** Aborting ***
[ 29501.266]
Fatal server error:
[ 29501.266] AddScreen/ScreenInit failed for driver 0

Here’s the whole log:
[ 29499.443]
X.Org X Server 1.13.0
Release Date: 2012-09-05
[ 29499.444] X Protocol Version 11, Revision 0
[ 29499.444] Build Operating System: c6b9 2.6.32-220.el6.x86_64
[ 29499.445] Current Operating System: Linux asterisk.######.net 3.10.29-11.el6.centos.alt.x86_64 #1 SMP Tue Feb 11 22:00:02 UTC 2014 x86_64
[ 29499.445] Kernel command line: ro root=UUID=526b6299-50bd-4688-a552-966bb80116f9 rd_NO_LUKS rd_NO_LVM LANG=en_US.UTF-8 rd_NO_MD SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM crashkernel=auto rdblacklist=nouveau nomodeset
[ 29499.446] Build Date: 20 December 2013 12:09:45PM
[ 29499.446] Build ID: xorg-x11-server 1.13.0-23.1.el6.centos
[ 29499.447] Current version of pixman: 0.26.2
[ 29499.447] Before reporting problems, check http://wiki.centos.org/Documentation

to make sure that you have the latest version.
[ 29499.447] Markers: (–) probed, () from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 29499.453] (==) Log file: “/var/log/Xorg.0.log”, Time: Wed Feb 19 08:01:56 2014
[ 29499.490] (==) Using config file: “/etc/X11/xorg.conf”
[ 29499.491] (==) Using system config directory “/usr/share/X11/xorg.conf.d”
[ 29499.494] (==) ServerLayout “Simple Layout”
[ 29499.494] (
) |–>Screen “Screen0” (0)
[ 29499.494] () | |–>Monitor “Monitor0”
[ 29499.494] (
) | |–>Device “Device0”
[ 29499.494] () |–>Input Device “Mouse1”
[ 29499.494] (
) |–>Input Device “Keyboard1”
[ 29499.494] () Option “Xinerama” “0”
[ 29499.494] (==) Automatically adding devices
[ 29499.494] (==) Automatically enabling devices
[ 29499.494] (==) Not automatically adding GPU devices
[ 29499.495] (WW) The directory “/usr/X11/lib/X11/fonts/TrueType/” does not exist.
[ 29499.495] Entry deleted from font path.
[ 29499.495] (WW) The directory “/usr/X11/lib/X11/fonts/Type1/” does not exist.
[ 29499.495] Entry deleted from font path.
[ 29499.495] (WW) The directory “/usr/X11/lib/X11/fonts/Type1/sun/” does not exist.
[ 29499.495] Entry deleted from font path.
[ 29499.495] (WW) The directory “/usr/X11/lib/X11/fonts/F3bitmaps/” does not exist.
[ 29499.495] Entry deleted from font path.
[ 29499.495] (WW) The directory “/usr/X11/lib/X11/fonts/misc/” does not exist.
[ 29499.495] Entry deleted from font path.
[ 29499.495] (WW) The directory “/usr/X11/lib/X11/fonts/100dpi/” does not exist.
[ 29499.495] Entry deleted from font path.
[ 29499.495] (WW) The directory “/usr/X11/lib/X11/fonts/75dpi/” does not exist.
[ 29499.495] Entry deleted from font path.
[ 29499.495] (
) FontPath set to:
catalogue:/etc/X11/fontpath.d,
built-ins
[ 29499.495] (==) ModulePath set to “/usr/lib64/xorg/modules”
[ 29499.495] (WW) Hotplugging is on, devices using drivers ‘kbd’, ‘mouse’ or ‘vmmouse’ will be disabled.
[ 29499.495] (WW) Disabling Mouse1
[ 29499.495] (WW) Disabling Keyboard1
[ 29499.495] (II) Loader magic: 0x813020
[ 29499.495] (II) Module ABI versions:
[ 29499.495] X.Org ANSI C Emulation: 0.4
[ 29499.495] X.Org Video Driver: 13.1
[ 29499.495] X.Org XInput driver : 18.1
[ 29499.495] X.Org Server Extension : 7.0
[ 29499.498] (–) PCI:*(0:1:0:0) 10de:0640:10de:0648 rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf4000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x???/524288
[ 29499.499] Initializing built-in extension Generic Event Extension
[ 29499.500] Initializing built-in extension SHAPE
[ 29499.500] Initializing built-in extension MIT-SHM
[ 29499.500] Initializing built-in extension XInputExtension
[ 29499.501] Initializing built-in extension XTEST
[ 29499.501] Initializing built-in extension BIG-REQUESTS
[ 29499.501] Initializing built-in extension SYNC
[ 29499.501] Initializing built-in extension XKEYBOARD
[ 29499.502] Initializing built-in extension XC-MISC
[ 29499.502] Initializing built-in extension SECURITY
[ 29499.502] Initializing built-in extension XINERAMA
[ 29499.502] Initializing built-in extension XFIXES
[ 29499.503] Initializing built-in extension RENDER
[ 29499.503] Initializing built-in extension RANDR
[ 29499.503] Initializing built-in extension COMPOSITE
[ 29499.504] Initializing built-in extension DAMAGE
[ 29499.504] Initializing built-in extension MIT-SCREEN-SAVER
[ 29499.504] Initializing built-in extension DOUBLE-BUFFER
[ 29499.505] Initializing built-in extension RECORD
[ 29499.505] Initializing built-in extension DPMS
[ 29499.505] Initializing built-in extension X-Resource
[ 29499.505] Initializing built-in extension XVideo
[ 29499.506] Initializing built-in extension XVideo-MotionCompensation
[ 29499.506] Initializing built-in extension SELinux
[ 29499.506] Initializing built-in extension XFree86-VidModeExtension
[ 29499.507] Initializing built-in extension XFree86-DGA
[ 29499.507] Initializing built-in extension XFree86-DRI
[ 29499.507] Initializing built-in extension DRI2
[ 29499.507] (II) “glx” will be loaded. This was enabled by default and also specified in the config file.
[ 29499.507] (II) LoadModule: “dbe”
[ 29499.509] (II) Module “dbe” already built-in
[ 29499.509] (II) LoadModule: “extmod”
[ 29499.509] (II) Module “extmod” already built-in
[ 29499.509] (II) LoadModule: “glx”
[ 29499.513] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[ 29499.813] (II) Module glx: vendor=“NVIDIA Corporation”
[ 29499.814] compiled for 4.0.2, module version = 1.0.0
[ 29499.814] Module class: X.Org Server Extension
[ 29499.814] (II) NVIDIA GLX Module 331.38 Wed Jan 8 19:10:17 PST 2014
[ 29499.820] Loading extension GLX
[ 29499.820] (II) LoadModule: “nvidia”
[ 29499.833] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[ 29499.835] (II) Module nvidia: vendor=“NVIDIA Corporation”
[ 29499.835] compiled for 4.0.2, module version = 1.0.0
[ 29499.835] Module class: X.Org Video Driver
[ 29499.835] (II) NVIDIA dlloader X Driver 331.38 Wed Jan 8 18:51:00 PST 2014
[ 29499.835] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 29499.835] (–) using VT number 7

[ 29499.844] (II) Loading sub module “fb”
[ 29499.844] (II) LoadModule: “fb”
[ 29499.944] (II) Loading /usr/lib64/xorg/modules/libfb.so
[ 29500.065] (II) Module fb: vendor=“X.Org Foundation”
[ 29500.065] compiled for 1.13.0, module version = 1.0.0
[ 29500.065] ABI class: X.Org ANSI C Emulation, version 0.4
[ 29500.065] (WW) Unresolved symbol: fbGetGCPrivateKey
[ 29500.065] (II) Loading sub module “wfb”
[ 29500.065] (II) LoadModule: “wfb”
[ 29500.065] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[ 29500.116] (II) Module wfb: vendor=“X.Org Foundation”
[ 29500.116] compiled for 1.13.0, module version = 1.0.0
[ 29500.116] ABI class: X.Org ANSI C Emulation, version 0.4
[ 29500.116] (II) Loading sub module “ramdac”
[ 29500.116] (II) LoadModule: “ramdac”
[ 29500.116] (II) Module “ramdac” already built-in
[ 29500.268] () NVIDIA(0): Depth 24, (–) framebuffer bpp 32
[ 29500.268] (==) NVIDIA(0): RGB weight 888
[ 29500.268] (==) NVIDIA(0): Default visual is TrueColor
[ 29500.268] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 29500.268] (
) NVIDIA(0): Option “Stereo” “0”
[ 29500.268] () NVIDIA(0): Stereo disabled by request
[ 29500.268] (
) NVIDIA(0): Option “MetaModes” “1280x1024_60 +0+0; 1024x768 +0+0; 800x600 +0+0; 640x480 +0+0”
[ 29500.268] () NVIDIA(0): Enabling 2D acceleration
[ 29501.152] (WW) NVIDIA(0): Unable to read EDID for display device CRT-1
[ 29501.152] (II) NVIDIA(GPU-0): Found DRM driver nvidia-drm (20130102)
[ 29501.153] (II) NVIDIA(0): NVIDIA GPU GeForce 9500 GT (G96) at PCI:1:0:0 (GPU-0)
[ 29501.153] (–) NVIDIA(0): Memory: 524288 kBytes
[ 29501.153] (–) NVIDIA(0): VideoBIOS: 62.94.4b.00.00
[ 29501.153] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[ 29501.154] (–) NVIDIA(0): Valid display device(s) on GeForce 9500 GT at PCI:1:0:0
[ 29501.154] (–) NVIDIA(0): CRT-0
[ 29501.154] (–) NVIDIA(0): CRT-1 (boot, connected)
[ 29501.154] (–) NVIDIA(0): TV-0
[ 29501.154] (–) NVIDIA(0): DFP-0
[ 29501.154] (–) NVIDIA(0): DFP-1
[ 29501.154] (–) NVIDIA(0): DFP-2
[ 29501.154] (–) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
[ 29501.154] (–) NVIDIA(0): CRT-1: 400.0 MHz maximum pixel clock
[ 29501.154] (–) NVIDIA(0): TV-0: 400.0 MHz maximum pixel clock
[ 29501.154] (–) NVIDIA(0): DFP-0: Internal Single Link TMDS
[ 29501.154] (–) NVIDIA(0): DFP-0: 330.0 MHz maximum pixel clock
[ 29501.154] (–) NVIDIA(0): DFP-1: Internal Single Link TMDS
[ 29501.154] (–) NVIDIA(0): DFP-1: 330.0 MHz maximum pixel clock
[ 29501.154] (–) NVIDIA(0): DFP-2: Internal Single Link TMDS
[ 29501.154] (–) NVIDIA(0): DFP-2: 330.0 MHz maximum pixel clock
[ 29501.154] (
) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[ 29501.154] () NVIDIA(0): device CRT-1 (Using EDID frequencies has been enabled on
[ 29501.154] (
) NVIDIA(0): all display devices.)
[ 29501.162] (II) NVIDIA(0): Validated MetaModes:
[ 29501.162] (II) NVIDIA(0): “1280x1024_60+0+0”
[ 29501.162] (II) NVIDIA(0): “1024x768+0+0”
[ 29501.162] (II) NVIDIA(0): “800x600+0+0”
[ 29501.162] (II) NVIDIA(0): “640x480+0+0”
[ 29501.162] (II) NVIDIA(0): Virtual screen size determined to be 1280 x 1024
[ 29501.192] (WW) NVIDIA(0): Unable to get display device CRT-1’s EDID; cannot compute DPI
[ 29501.192] (WW) NVIDIA(0): from CRT-1’s EDID.
[ 29501.192] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
[ 29501.192] (–) Depth 24 pixmap format is 32 bpp
[ 29501.193] (II) NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.
[ 29501.215] (II) NVIDIA(0): Setting mode “1280x1024_60+0+0”
[ 29501.243] (EE) NVIDIA(0): Failed to allocate sofware rendering cache surface: out of
[ 29501.243] (EE) NVIDIA(0): memory.
[ 29501.243] (EE) NVIDIA(0): *** Aborting ***
[ 29501.266]
Fatal server error:
[ 29501.266] AddScreen/ScreenInit failed for driver 0
[ 29501.266]
[ 29501.266] (EE)
Please consult the CentOS support
at http://wiki.centos.org/Documentation

for help.
[ 29501.266] (EE) Please also check the log file at “/var/log/Xorg.0.log” for additional information.
[ 29501.266] (EE)
[ 29501.282] Server terminated with error (1). Closing log file.

Hi i have similiar problem on ubuntu 13.10 (gtx 560). I am new to XEN (i want to learn it) i install xen hypervisor. Boot XEN kernel and try to install again nvidia driver (NVIDIA-Linux-x86_64-334.16.run) becouse i got black screen and i can not get terminal (ALT+F1 , F2 …) not work, keyboard also not work… on standard kernel(without XEN all works fine).

I dont know what can i do. Any Ideas?

Thanks for reporting this issue. Did you guys using xen kernel or XEN 4.0 hypervisor source? Plz provide nvidia bug report by running nvidia-bug-report.sh script as root user and step by step reproduction steps ?
From where I can get required apps?

Hi sorry for long time and my english too.
I try to install today clean ubuntu 13.10 to new hdd. There is my steps for reproduce.

  1. install ubuntu 13.10 64bit

  2. after installation run command:
    sudo apt-get update && sudo apt-get upgrade

  3. Download nvidia driver:
    mkdir nvidia-driver
    cd nvidia-driver
    http://uk.download.nvidia.com/XFree86/Linux-x86_64/331.49/NVIDIA-Linux-x86_64-331.49.run
    chmod +x NVIDIA-Linux-x86_64-331.49.run

  4. Verify which vga driver is used. At this moment must be nouveau opensource driver.
    lsmod |grep nouveau

  5. Reboot

  6. After reboot switch to TTY1. Just press ALT+F1 and login.

  7. Stop the xserver
    sudo service lightdm stop

  8. Install nvidia driver and disable nouveau(this is automated during try to install nvidia driver-need reboot and again run installer)
    cd nvidia-driver
    sudo ./NVIDIA-Linux-x86_64-331.49.run

  9. After installation reboot and login to Xsession

  10. Verify if now we run on nvidia driver:
    lsmod |grep nvidia

====NOW i install Xen hypervisor====

  1. install Xen
    sudo apt-get install xen-hypervisor-amd64 bridge-utils

  2. reboot and Quickly press and hold the Shift key, which will bring up the GRUB menu.

  3. Chose Xen Hypervisor

  4. Then show only black screen. No chance to switch to TTY1 with ALT+F1. I can only press reboot button on case. Then i can hold shift to boot-menu and chose advanced mode. I try reinstall driver from advance mode but no luck stiil black on xen kernel. But on generic ubuntu kernel(without XEN work fine.)

I add nvidia-bug-report.log.gz to attachment

or download from: https://docs.google.com/file/d/0B-lfYbTciVE4bi1IWXRVR002eVU/edit

//added my system specification
OS: Ubuntu 64 bit 13.10
mainboard: Gigabyte GA-Z77-D3H (socket 1155)
cpu: i7 3770
VGA: asus gtx 560
RAM: 8GB Crucial Ballistix low profile
HDD: 1T Seagate baracuda
Power: 600W
nvidia-bug-report.log.gz (57.6 KB)

Nothink new?

I have had the exact same problem, for several months now, also using XEN. I have a SLI configuration with two GeForce 9 9800GT cards. The symptoms are:

  1. X server won’t start.
  2. TTY terminals are unavailable after trying to start the X server.

I have the same error messages, again “sofware” with no “T”.

[ 27.975] (EE) NVIDIA(0): Failed to allocate sofware rendering cache surface: out of
[ 27.975] (EE) NVIDIA(0): memory.
[ 27.975] (EE) NVIDIA(0): *** Aborting ***
[ 28.016] (EE)
[ 28.016] (EE) AddScreen/ScreenInit failed for driver 0
[ 28.016] (EE)
[ 28.016] (EE)
[ 28.016] (EE) Please also check the log file at “/var/log/Xorg.0.log” for additional information.
[ 28.016] (EE)
[ 28.071] (EE) Server terminated with error (1). Closing log file.

I also noticed that after the driver has been loaded for a few minutes, if one tries to stop and restart the x-server, the revision numbering changes on the second graphics card:

  1. After booting, lspci shows:
    04:00.0 VGA compatible controller: NVIDIA Corporation G92 [GeForce 9800 GT] (rev a2)
    05:00.0 VGA compatible controller: NVIDIA Corporation G92 [GeForce 9800 GT] (rev a2)

  2. AFTER - /etc/init.d/xdm stop:
    04:00.0 VGA compatible controller: NVIDIA Corporation G92 [GeForce 9800 GT] (rev a2)
    05:00.0 VGA compatible controller: NVIDIA Corporation G92 [GeForce 9800 GT] (rev ff)

After it changes to “rev ff” the driver won’t recognize the card anymore:

[ 678.667] (EE) NVIDIA(GPU-1): Failed to initialize the NVIDIA GPU at PCI:5:0:0. Please
[ 678.667] (EE) NVIDIA(GPU-1): check your system’s kernel log for additional error
[ 678.667] (EE) NVIDIA(GPU-1): messages and refer to Chapter 8: Common Problems in the
[ 678.667] (EE) NVIDIA(GPU-1): README for additional information.
[ 678.667] (EE) NVIDIA(GPU-1): Failed to initialize the NVIDIA graphics device!
[ 678.702] (EE) NVIDIA(0): Failed to allocate sofware rendering cache surface: out of
[ 678.702] (EE) NVIDIA(0): memory.
[ 678.702] (EE) NVIDIA(0): *** Aborting ***
[ 678.727] (EE)
[ 678.727] (EE) AddScreen/ScreenInit failed for driver 0
[ 678.728] (EE)
[ 678.728] (EE)
[ 678.728] (EE) Please also check the log file at “/var/log/Xorg.0.log” for additional information.
[ 678.728] (EE)
[ 678.782] (EE) Server terminated with error (1). Closing log file.

#SYSLOG:
kernel: [ 681.350164] NVRM: request_irq() failed (-22)
kernel: [ 681.350168] NVRM: nvidia_frontend_open: minor 1, module->open() failed, error -22

04:00.0 VGA compatible controller: NVIDIA Corporation G92 [GeForce 9800 GT] (rev a2) (prog-if 00 [VGA controller])
Subsystem: eVga.com. Corp. Device c981
Flags: bus master, fast devsel, latency 0, IRQ 19
Memory at f7000000 (32-bit, non-prefetchable)
Memory at c0000000 (64-bit, prefetchable)
Memory at f4000000 (64-bit, non-prefetchable)
I/O ports at cc00
[virtual] Expansion ROM at f6fe0000 [disabled]
Capabilities: [60] Power Management version 3
Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [78] Express Endpoint, MSI 00
Capabilities: [100] Virtual Channel
Capabilities: [128] Power Budgeting <?>
Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
Kernel driver in use: nvidia
Kernel modules: nvidia
00: de 10 05 06 07 00 10 00 a2 00 00 03 00 00 00 00
10: 00 00 00 f7 0c 00 00 c0 00 00 00 00 04 00 00 f4
20: 00 00 00 00 01 cc 00 00 00 00 00 00 42 38 81 c9
30: 00 00 00 00 60 00 00 00 00 00 00 00 0a 01 00 00
40: 42 38 81 c9 00 00 00 00 00 00 00 00 00 00 00 00
50: 01 00 00 00 01 00 00 00 ce d6 23 00 00 00 00 00
60: 01 68 03 00 08 00 00 00 05 78 80 00 0c 10 e0 fe
70: 00 00 00 00 81 41 00 00 10 00 02 00 e0 84 00 00
80: 10 29 00 00 02 2d 00 00 48 00 02 11 00 00 00 00
90: 00 00 00 00 00 00 00 00 00 00 00 00 10 00 00 00
a0: 00 00 00 00 00 00 00 00 02 00 00 00 00 00 00 00
b0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
c0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
d0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
e0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
f0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

05:00.0 VGA compatible controller: NVIDIA Corporation G92 [GeForce 9800 GT] (rev ff) (prog-if ff)
!!! Unknown header type 7f
Kernel driver in use: nvidia
Kernel modules: nvidia
00: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
10: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
20: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
40: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
80: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
90: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
a0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
b0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
c0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
d0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
e0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
f0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff

If I roll back to an older version, such as 319.49, there are no problems.
How do we get this fixed? Thank you for your help with it.

ftarz, how much memory is available in your Xen dom0 environment? The allocation that’s failing defaults to 8 MB, which is awfully small to be exhausting memory. You can set the SoftwareRenderCacheSize option to 1 to get the minimum size for the cache, if that helps.

you_know_who, your second problem is caused by something in your system cutting power to the second GPU.

Hi aplattner,

Thank you for the reply. So do we suppose setting the “SoftwareRenderCacheSize” option to 1 will resolve the issue? This DOM0 has 16GB of memory available.

Also, why do we think the power is being cut? This never happens using the exact same system and using the older driver. Are we suggesting that the PSU is just arbitrarily killing the power on the 2nd GPU? That seems odd that this would happen only when using the new driver. This has never happened using 319.49.

Thank you again for your thoughts and input.

Hi again, yesterday and today i again try XEN and nvidia. Now i take centOS 6.5(64bi) then i install nvidia 331.67 work but after i install XEN(http://wiki.centos.org/HowTos/Xen/Xen4QuickStart) then reboot start XEN kernel and again install nvidia driver for XEN kernel. But not work. There is syslog msg:

NVRM: RmInitAdapter failed! (0x26:0x38:1191)
NVRM: rm_init_adapter failed for device bearing minor number 0
NVRM: nvidia_frontend_open: minor 0, module->open() failed, error -5

full dmesg is here http://pastebin.com/tcNKDbfg

And there is Xorg.O.log msg:

[    36.547] 
X.Org X Server 1.13.0
Release Date: 2012-09-05
[    36.548] X Protocol Version 11, Revision 0
[    36.548] Build Operating System: c6b9 2.6.32-220.el6.x86_64 
[    36.549] Current Operating System: Linux XenServer-centos 3.10.34-11.el6.centos.alt.x86_64 #1 SMP Fri Mar 28 00:57:43 UTC 2014 x86_64
[    36.549] Kernel command line: ro root=UUID=ccf34c5f-68b6-4f47-ae84-537825127456 nomodeset rd_NO_LUKS KEYBOARDTYPE=pc KEYTABLE=sk-qwerty rd_NO_MD SYSFONT=latarcyrheb-sun16 crashkernel=auto LANG=sk_SK.UTF-8 rd_NO_LVM rd_NO_DM rhgb quiet
[    36.551] Build Date: 20 December 2013  12:09:45PM
[    36.551] Build ID: xorg-x11-server 1.13.0-23.1.el6.centos 
[    36.551] Current version of pixman: 0.26.2
[    36.552] 	Before reporting problems, check http://wiki.centos.org/Documentation
	to make sure that you have the latest version.
[    36.552] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    36.554] (==) Log file: "/var/log/Xorg.0.log", Time: Mon May 19 11:58:56 2014
[    36.556] (==) Using config file: "/etc/X11/xorg.conf"
[    36.556] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    36.557] (==) ServerLayout "Layout0"
[    36.557] (**) |-->Screen "Screen0" (0)
[    36.557] (**) |   |-->Monitor "Monitor0"
[    36.557] (**) |   |-->Device "Device0"
[    36.557] (**) |-->Input Device "Keyboard0"
[    36.557] (**) |-->Input Device "Mouse0"
[    36.557] (==) Automatically adding devices
[    36.557] (==) Automatically enabling devices
[    36.557] (==) Not automatically adding GPU devices
[    36.558] (**) FontPath set to:
	/usr/share/fonts/default/Type1,
	catalogue:/etc/X11/fontpath.d,
	built-ins
[    36.558] (==) ModulePath set to "/usr/lib64/xorg/modules"
[    36.558] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    36.558] (WW) Disabling Keyboard0
[    36.558] (WW) Disabling Mouse0
[    36.558] (II) Loader magic: 0x813020
[    36.558] (II) Module ABI versions:
[    36.558] 	X.Org ANSI C Emulation: 0.4
[    36.558] 	X.Org Video Driver: 13.1
[    36.558] 	X.Org XInput driver : 18.1
[    36.558] 	X.Org Server Extension : 7.0
[    36.559] (--) PCI:*(0:1:0:0) 10de:1201:1043:83ae rev 161, Mem @ 0xf4000000/33554432, 0xe8000000/134217728, 0xf0000000/67108864, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[    36.559] Initializing built-in extension Generic Event Extension
[    36.560] Initializing built-in extension SHAPE
[    36.560] Initializing built-in extension MIT-SHM
[    36.560] Initializing built-in extension XInputExtension
[    36.561] Initializing built-in extension XTEST
[    36.561] Initializing built-in extension BIG-REQUESTS
[    36.561] Initializing built-in extension SYNC
[    36.562] Initializing built-in extension XKEYBOARD
[    36.562] Initializing built-in extension XC-MISC
[    36.562] Initializing built-in extension SECURITY
[    36.563] Initializing built-in extension XINERAMA
[    36.563] Initializing built-in extension XFIXES
[    36.563] Initializing built-in extension RENDER
[    36.564] Initializing built-in extension RANDR
[    36.564] Initializing built-in extension COMPOSITE
[    36.564] Initializing built-in extension DAMAGE
[    36.565] Initializing built-in extension MIT-SCREEN-SAVER
[    36.565] Initializing built-in extension DOUBLE-BUFFER
[    36.565] Initializing built-in extension RECORD
[    36.566] Initializing built-in extension DPMS
[    36.566] Initializing built-in extension X-Resource
[    36.566] Initializing built-in extension XVideo
[    36.567] Initializing built-in extension XVideo-MotionCompensation
[    36.567] Initializing built-in extension SELinux
[    36.567] Initializing built-in extension XFree86-VidModeExtension
[    36.568] Initializing built-in extension XFree86-DGA
[    36.568] Initializing built-in extension XFree86-DRI
[    36.569] Initializing built-in extension DRI2
[    36.569] (II) "glx" will be loaded by default.
[    36.569] (II) LoadModule: "dri2"
[    36.569] (II) Module "dri2" already built-in
[    36.569] (II) LoadModule: "glamoregl"
[    36.571] (WW) Warning, couldn't open module glamoregl
[    36.571] (II) UnloadModule: "glamoregl"
[    36.571] (II) Unloading glamoregl
[    36.571] (EE) Failed to load module "glamoregl" (module does not exist, 0)
[    36.571] (II) LoadModule: "glx"
[    36.571] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    36.631] (II) Module glx: vendor="NVIDIA Corporation"
[    36.631] 	compiled for 4.0.2, module version = 1.0.0
[    36.631] 	Module class: X.Org Server Extension
[    36.631] (II) NVIDIA GLX Module  331.67  Fri Apr  4 11:43:47 PDT 2014
[    36.631] Loading extension GLX
[    36.631] (II) LoadModule: "nvidia"
[    36.632] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[    36.637] (II) Module nvidia: vendor="NVIDIA Corporation"
[    36.637] 	compiled for 4.0.2, module version = 1.0.0
[    36.637] 	Module class: X.Org Video Driver
[    36.638] (II) NVIDIA dlloader X Driver  331.67  Fri Apr  4 11:24:40 PDT 2014
[    36.638] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    36.639] (--) using VT number 7

[    36.658] (II) Loading sub module "fb"
[    36.659] (II) LoadModule: "fb"
[    36.659] (II) Loading /usr/lib64/xorg/modules/libfb.so
[    36.660] (II) Module fb: vendor="X.Org Foundation"
[    36.660] 	compiled for 1.13.0, module version = 1.0.0
[    36.660] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    36.660] (WW) Unresolved symbol: fbGetGCPrivateKey
[    36.660] (II) Loading sub module "wfb"
[    36.660] (II) LoadModule: "wfb"
[    36.660] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[    36.661] (II) Module wfb: vendor="X.Org Foundation"
[    36.661] 	compiled for 1.13.0, module version = 1.0.0
[    36.661] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    36.661] (II) Loading sub module "ramdac"
[    36.661] (II) LoadModule: "ramdac"
[    36.661] (II) Module "ramdac" already built-in
[    36.664] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    36.664] (==) NVIDIA(0): RGB weight 888
[    36.664] (==) NVIDIA(0): Default visual is TrueColor
[    36.664] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    36.664] (**) NVIDIA(0): Option "TripleBuffer" "1"
[    36.664] (**) NVIDIA(0): Enabling 2D acceleration
[    45.079] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please
[    45.079] (EE) NVIDIA(GPU-0):     check your system's kernel log for additional error
[    45.079] (EE) NVIDIA(GPU-0):     messages and refer to Chapter 8: Common Problems in the
[    45.079] (EE) NVIDIA(GPU-0):     README for additional information.
[    45.079] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA graphics device!
[    45.079] (EE) NVIDIA(0): Failing initialization of X screen 0
[    45.079] (II) UnloadModule: "nvidia"
[    45.079] (II) UnloadSubModule: "wfb"
[    45.079] (II) UnloadSubModule: "fb"
[    45.079] (EE) Screen(s) found, but none have a usable configuration.
[    45.079] 
Fatal server error:
[    45.079] no screens found
[    45.079] (EE) 
Please consult the CentOS support 
	 at http://wiki.centos.org/Documentation
 for help. 
[    45.079] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    45.079] (EE) 
[    45.091] Server terminated with error (1). Closing log file.

I try before ubuntu(5 posts above) and it is same.

NVIDIA please please fix it.

Hello People:

Can anyone help us to get this resolved? I am still having the same problem with the latest kernel and the latest NVidia drivers. I have tried adjusting the “SoftwareRenderCacheSize” option but I am still not having any luck.

Any ideas or thoughts would be much appreciated.

Hi guys,

I’m facing the same issue on my Ubuntu 12.04 with GeForce GTX 750 Ti video card and Xen4.1.
I tried 334.21 and latest 337.25 drivers but no luck.

Have anybody managed to fight this problem? Unfortunately I don’t have any driver version that I can fall back to. 319.49 doesn’t work for me as it is no compatible with GTX 750 Ti.

Please, advice.
Sergey

Hi Sergey:

Thank you for posting. I am still having the same problem and no luck. Like I mentioned, I tried working with the “SoftwareRenderCacheSize” parameter but I was never able to get it working again.

I ended up having to rollback to x86_64 kernel and not use the Xen hypervisor. I’m sad about this because I would rather use the hypervisor instead and it was great that the driver was working with it.

Hopefully there will be enough people that come along and post and somebody might see the forum and have the knowledge to know how to get it fixed.

Not sure this helps, but it might be worth trying: http://wiki.centos.org/HowTos/Xen/NvidiaWithXen.

The Nvidia driver wouldn’t normally install on Xen, but the above work-around might work. I haven’t tried it, but users on the Xen user mailing list confirmed that there is a workaround for Nvidia under dom0.

When will Nvidia fix this issue? For some reason the Nvidia driver doesn’t install under Xen, or refuses to work when detecting Xen. This is why the driver needs to be compiled specifically for Xen. By the way, AMD has no such issue and works fine under Xen.

Hope you get it working.

Hi powerhouse64:

Thank you for the post. Also, thank you for sharing the information about AMD. This is an interesting tidbit.

Yes, using the “IGNORE_XEN_PRESENCE=y” for compiling the module is widely known and it’s the only way to get it working under Xen as far as I know; this is the only way I have ever had any success in getting it running under Xen. This is a known issue. I would bet that all the Xen users posting on this page are installing the NVIDIA driver this way under Xen (using “IGNORE_XEN_PRESENCE=y”). This has been a known issue for a long time. Without it, one cannot even load the module under Xen (a modprobe command will not load the nvidia module and lsmod will not produce any output showing that the nvidia kernel module was loaded). So I am sure that the users on the Xen user mailing list are correct - I have loaded the nvidia kernel module like this for years without ever having any problems.

But it’s important to point out, however, that this isn’t the problem we’re dealing with in this post, and this problem that we’re describing here is completely different. The problem I am experiencing, and the same of the original poster, includes something similar to the following error message:

[   563.644] (EE) NVIDIA(0): Failed to allocate sofware rendering cache surface: out of
[   563.644] (EE) NVIDIA(0):     memory.
[   563.644] (EE) NVIDIA(0):  *** Aborting ***
[   564.091] (EE)
Fatal server error:
[   564.091] (EE) AddScreen/ScreenInit failed for driver 0
[   564.091] (EE)
[   564.091] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[   564.091] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   564.091] (EE)
[   564.146] (EE) Server terminated with error (1). Closing log file.

It’s not that the driver isn’t being recognized or ignored - it’s definitely getting loaded. But instead, it’s failing with the “sofware” error message (notice that there’s no “T” in software, like other posters have pointed out).

The module definitely gets loaded using the modprobe command (or automatically using modprobe.d); lsmod and the log clearly show that the module get successfully loaded. But when the X server is started, it produces a black screen, and also renders any geTTY consoles unviewable, also with a black screen.

I have also tried varying configurations, making adjustments to the xorg configuration file, and again, I am always ending up with the same result.

I just tried it with one of the newer versions of the Linux kernel, but the same problem continues. I have again rolled back to a kernel that cannot be used for a dom0 under the hypervisor to get video back.

Hopefully we can get some knowledgeable people from NVIDIA to tell us what this means and what should be done for it to get fixed.

I had a similar problem, and as far as I can tell, the trick is to use an older driver rather than a newer one. I am using an 8800GT card, and the most recent driver I managed to get working working without problems is the 319.xx series (latest of those is 319.82). All later drivers result in a Xorg crash/freeze as soon as it starts, before anything is drawn on the screen. The only problem is that the latest kernel 319.xx drivers work with is, IIRC 3.10.x. You will need to patch the driver to make it work on later kernels.

Same problem here. Xubuntu 14.04.1, GeForce GTX 780 Ti, driver 331.38 (the one packaged by Ubuntu). I installed the machine this morning. The graphics work fine when booted natively, but when I reboot with Xen and Linux as Dom0 it fails. As soon as the X server starts, the screen goes blank and none of the text consoles are accessible. It reports the same out-of-memory error message:

...
[    21.757] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[    21.757] (II) NVIDIA:     access.
[    22.155] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select,DFP-3:nvidia-auto-select,DFP-4:nvidia-auto-select"
[    22.311] (EE) NVIDIA(0): Failed to allocate sofware rendering cache surface: out of
[    22.311] (EE) NVIDIA(0):     memory.
[    22.311] (EE) NVIDIA(0):  *** Aborting ***
[    22.393] (EE)
Fatal server error:
[    22.393] (EE) AddScreen/ScreenInit failed for driver 0

I was able to compare this to a log from a successful run when booted without Xen:

...
[  2009.901] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[  2009.901] (II) NVIDIA:     access.
[  2010.292] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select,DFP-3:nvidia-auto-select,DFP-4:nvidia-auto-select"
[  2010.458] Loading extension NV-GLX
[  2010.550] (==) NVIDIA(0): Disabling shared memory pixmaps
[  2010.550] (==) NVIDIA(0): Backing store enabled
[  2010.550] (==) NVIDIA(0): Silken mouse enabled
[  2010.550] (==) NVIDIA(0): DPMS enabled
...

The logs are otherwise basically identical up to that point. Dom0 throws an error while the native boot instead loads NV-GLX and continues setting things up.

Our current Linux driver does not support Xen. This is already a known issue or unsupported configuration.

I’m glad you are aware that there is this huge regression of “no longer working with Xen” in the driver, but it would have been infinitely more helpful to provide information on:

  1. What the last driver that works with Xen is
  2. When you are likely to get it working again

Hi Sandip,

Thank you for the post.

Yes, I think that it’s a known issue that the driver has never really been supported under Xen. As a side note, I think that the developers at NVIDIA should re-think this position and notice that they do have a loyal customer base in the GNU/Linux community. But this is beside the point.

The real point is, despite the fact that the driver hasn’t been supported under Xen, most people, like we have already pointed out, have been able to get it running anyway. But this is a new error message when it worked with previous versions? There’s something that has obviously changed, and it really looks like that there was hasty development because the spelling in the error messages isn’t even correct.

I think that there’s certainly somebody at NVIDIA that could tell us more about this problem and give us a better and perhaps a more technical answer than simply posting that it’s not supported (which we already knew anyway).

Just for the record I also tried driver 340.24 (through the Ubuntu “xorg-edgers” PPA) and it’s got the same problem with the same “Failed to allocate sofware rendering cache surface” message. Hopefully since this is a known issue it will be fixed at some point?

Driver 319.82 does appear to work under Xen Dom0 once a patch is added so that it will compile against a recent kernel, and it does recognize my 780 Ti: http://lists.xen.org/archives/html/xen-devel/2014-07/msg02868.html. I still lose all my text consoles but at least I get X11, so that’s a start. After a quick test I still have lots of problems with OpenGL applications crashing or misbehaving, but that’s probably due to installing the driver manually because for example it doesn’t update the library paths the way Ubuntu expects.