Can't start X with 2080ti (Driver 415.18-1): RmInitAdapterFailed!

Hello there,

I just got my new machine and I went through installing a complete new Archlinux, but I can not get X to start.
What happens when I try to start is the “normal” prompt of X starting then the screen gets garbled with magenta strokes for a few seconds, then X “gives up” with the following:

xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

Looking at the Xorg.0.log I have nothing interesting but dmesg shows

NVRM: RmInitiAdapterFailed! (0x26:0x65:1098)
NVRM: rm_init_adapted failed for device bearing minor number 0

Here is the bug_report attached.
I’ve tried to update the BIOS but to no avail.
Any hints on how to proceed?

nvidia-bug-report.log.gz (526 KB)

Maybe start with a hardware-check, check if all power connectors are plugged, reseat the card, try a different slot, if possible. Double-check installing Windows.

What version of libpciaccess do you have installed? Similar thing happened to me where Xorg could not find the card which showed up correctly with lspci -vvv command. Updating it to version 0.14 solved that problem.

Thanks for the the answers.

@sambo57u The install is fresh from yesterday, everything is up-to-date (to the latest versions available in the arch reps). The libpciaccess is indeed 0.14.

@generix I’ve tried to switch to a different slot, exactly the same result. I’ve tried to replug the power but nothing changed… I’m installing windows now and we’ll see if it works better. Let’s hope it’s something easily fixable.

So Windows exhibits the same behavior, with different versions of the driver. I’ve contacted support and they are sending me a new card to try, but that will have to wait until Monday.