catastrophic error detected :-S Not sure how did that happened

1>D:\Program Files (x86)\Microsoft Visual Studio 8\VC\INCLUDE\xutility(870): internal error: assertion failed at: “D:/Bld/rel/gpgpu/toolkit/r2.0/compiler/edg/EDG_3.9/src/lower_name.c”, line 4179
1>1 catastrophic error detected in the compilation of “md5_kernel.cpp1.ii”.
1>Compilation aborted.
1>This application has requested the Runtime to terminate it in an unusual way.
1>Please contact the application’s support team for more information.

Last thing that I was doing before this thing occured:

  • Converted another project in solution to Intel C++, and back
  • Compilled another project in solution in 64bit, while CUDA project was 32 bit (not 64bit SDK installed)

After that this error occured.
I’ve discovered that syntax errors are detected without that error, but if code is correct - this things occurs. md5_kernel.cpp1.ii is 4.2mb long, not sure if it could help anyone.

Any ideas how I can fix that?

Ok, that was hard.


That was the cause :-)
I would be happy to see more meaningful error message :-)

Getting the same error on Windows Server 2003 64bit edition, with NVIDIA 260 card and CUDA SDK ver. 2.0.
Created project in Visual Studio 2005 (CUDA project, empty), added single cu file known to work before, and tried to compile.
Any comments are appreciated.

Update to the latest version of CUDA. CUDA 2.2 and newer can support most of the c++ stuff (in host code) that you can throw at it. There are a few advanced libs in boost that still cause it to choke IIRC.

VS 2005 SP1 is a better choice. It helped me get rid of the problem above without upgrading to CUDA.

But yes, You should definitely consider to the latest version of CUDA.

True, I updated to 2.3 and it helped. Assuming that SP1 for VS is 450 MB, updating CUDA is better choice :rolleyes: