Changing APPSIZE leads to tegraflash errors


I’ve seen similar topics on this matter exchange but didn’t provide a solution that worked for me.
I had successfully set up a dual bank rootfs on Xavier NX eMMC devkit (16GB). I had changed the rootfs partition size to 6G and added a data partition of 2G. This XML worked with L4T 32.6.1.

I’m trying to upgrade to L4T 35.1 to benefit from the 5.10 kernel. However, I noticed that the base xml has changed (flash_l4t_t194_spi_emmc_p3668_rootfs_ab.xml). I tried to modify it with my rootfs size and new data partition but tegraflash was not working. I isolated the changes and noticed that the new rootfs size alone was problematic.

The isolated problem is the following.
I’m using:

  • flash_l4t_t194_spi_emmc_p3668_rootfs_ab.xml
  • APPSIZE = 6441402368 (6GB) (No problem with 7516192768 (7GB))
    tegradevflash_v2 is stuck when it tries to flash the APP partition at 0%. Meanwhile, the Xavier NX console displays the following error message:
[0338.604] I> Writing cpu-bootloader_b partition.
[0380.377] I> Writing bootloader-dtb_b partition.
[0384.912] I> Writing VER_b partition.
[0384.921] I> Writing VER partition.
[0384.930] I> Writing device 1: 3.
[0384.938] I> Writing APP partition.
[0384.974] E> NV3P_SERVER: Could not write 1048576 bytes.

Could you provide me with assistance on this matter?

Best Regards.


Could you test with EMMC_CFG=flash_l4t_t194_spi_emmc_p3668.xml first? Also, share the command you are using in

Thanks for your reply.

I encounter the same error with flash_l4t_t194_spi_emmc_p3668.xml along with APPSIZE=6442450944.

For flashing, I use a custom Yocto distribution which makes use of meta-tegra. It calls the script with the following arguments:

MACHINE=custom-xavier ./ custom-xavier.dtb tegra194-mb1-bct-memcfg-p3668-0001-a00.cfg,tegra194-memcfg-sw-override.cfg 0xB8190000 boot.img custom-dbg-image.ext4 "$@"

The issue arrives when the following tegradevflash command is called:

tegradevflash_v2 --pt flash.xml.bin --create

Sorry that we have no experience with Yocto tool. Please try to reproduce your error with and share your steps.

I’ve resolved my problem.
More info on the associated Issue on github/meta-tegra

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.