ChatRTX 0.3 Installation Failure creating the miniconda environment

The latest version of the application (ChatRTX 0.3 = ChatRTX_Installer_Mistral_4_24_Final.zip) does not work.

The installer crashes after a few seconds encountering an error in creating the miniconda environment.

I have no spaces in my username.

I tried installing in the default location, disabling the antivirus, manually setting a different location for miniconda (by editing the ChatRTX_Installer_Mistral_4_24_Final\ChatRTX\strings.dat file) and running the installer as administrator, but none of this changed the situation.

The previous version of the application (ChatRTX 0.2.1 = ChatWithRTX_installer_3_5.zip) works correctly without using any tricks during installation.

Could anyone provide me with support or direct me to where I can find answers???

1 Like

Same error under windows 10 (windows 11 is required) with rtx 3060 12go, xeon and 64 gb ram.
error on miniconda environnement, the previous version of chatrtx well installed and worked.
i modify the installation folder to d:\ and use the windows compatibility tool, and it does not work.
please share a solution

I had the some error.
Fist i edit file strings.dat with directory were i’ld install miniconda (with no space) inmy case d:\miniconda
and replace with new path.
In my case: … string name=“MiniCondaPath” value=“d:\MiniConda”/>

after edit also file app_launch.bat and app_launch_core.bat (in zip file).
Modify reference of MiniConda
(for /f "tokens=1,* delims= " %%a in (‘“d:\MiniConda\Scripts\conda.exe” env list’)
and
call “d:\MiniConda\Scripts\activate.bat” %env_path_found%

Try instal after error go in directory where you want instal chartx, launch command prompt ad paste
conda create --prefix ./env_nvd_rag python=3.10
if conda don’t recognize add path in user path (windows variables)
try install

maybie you don’t need

1 Like

The latest version of the application (ChatRTX 0.3 = ChatRTX_Installer_Mistral_4_24_Final.zip) does not work.

The installer crashes after a few seconds encountering an error in creating the miniconda environment.

I have no spaces in my username.

I tried installing in the default location, disabling the antivirus, manually setting a different location for miniconda (by editing the ChatRTX_Installer_Mistral_4_24_Final\ChatRTX\strings.dat file) and running the installer as administrator, but none of this changed the situation.

The previous version of the application (ChatRTX 0.2.1 = ChatWithRTX_installer_3_5.zip) works correctly without using any tricks during installation. So many issues since it launched. This app spoils lot of my time to install it. Tried all the procedure available in the internet but unsuccessful. Hope Nvidia will fix this.

Could anyone provide me with support or direct me to where I can find answers???

try to make your self virtual conda

go in directory where you want instal chartx, launch command prompt ad paste
conda create --prefix ./env_nvd_rag python=3.10

1 Like

Got conda prefix error, make sure you have sufficient permission

Same error. I tried everything with no luck.

Now i got the error, failed to install the dependency. I shut my antivirus and use vpn also. But the problem persist

go in directory where you want install chartx, launch command prompt ad paste
conda create --prefix ./env_nvd_rag python=3.10

have you an error? its create env?

Environment created, now the error is failed to install the dependency

try in prompt: conda activate D:\rtxllm\env_nvd_rag
d:\rtxlm must change with your instal directory

1 Like

Thank you, after all i am able to install it. I think this is due long system environment variable. I cleared all and after install it. Restore all environment variable

But now another problem, it opens and closed suddenly

Thank you, now it is working perfectly

Thank you! it worked perfectly!

Also try “conda create --prefix ./env_nvd_rag python=3.10 ca-certificates -c defaults -c conda-forge”! especially if you create the environment above and It can’t install ca-certificates.

Details: Slightly different solution for me: I have no space in my username so I did not have to change any string or path files. When I did “conda create --prefix ./env_nvd_rag python=3.10”, I got a cannot install ca-certificate error. Not sure if necessary but I uninstalled miniconda3 and reinstalled it from the ChatGTX installer directory (Downloads\ChatRTX_Installer_Mistral_4_24_Final\ChatRTX_Installer_Mistral_4_24_Final\Miniconda3-latest-Windows-x86_64.exe). Then I ran anaconda prompt and went to the ChatRTX directory and deleted all files from the failed attempts. Then “conda create --prefix ./env_nvd_rag python=3.10 ca-certificates -c defaults -c conda-forge”. It installed ca-certificates-2024.3.11-haa95532 which matches the version in the ChatRTX/dependencies/conda directory so I think that’s what fixed it. the -c defaults and -c conda-forge seems to get the right version for me. Miniconda 3.11 and a python 3.10 environment specification and changing the channel order- not sure which is really required. Then I ran the installer and it finished the install correctly.

I can hardly believe that this is considered “Solved”

Mabadil75 - Awesome job figuring this out. Thank you. However,

Dear Nvidia, can you please just patch the installer so I dont have to dink with dat files and variables please.

1 Like

I don’t understand. I tried but it states conda is not a recognized command. After all, it fails to create miniconda environment, how is it supposed to have conda working?

Summary of the Issue and Solution

Issue: The installation of NVIDIA ChatRTX 0.3 fails due to problems with creating the Miniconda environment, especially on systems running Windows 10 instead of Windows 11.

Solution:

  1. Install Miniconda: Install Miniconda to a directory without spaces (e.g., D:\MiniConda).
  2. Set PATH Environment Variables: Add D:\MiniConda, D:\MiniConda\Scripts, and D:\MiniConda\Library\bin to the system PATH.
  3. Manual Environment Setup: Navigate to the desired installation directory (e.g., D:\ChatRTX) and create the environment manually with conda create --prefix ./env_nvd_rag python=3.10.
  4. Re-run Installer: Run the ChatRTX installer and select the directory where the environment was created.

This method bypasses the automated environment creation process, which resolves the compatibility issues.

Step-by-Step Guide:

  1. Install Miniconda:
  • Download and install Miniconda to a directory without spaces, e.g., D:\MiniConda.
  1. Add Miniconda to PATH Environment Variable:
  • Open System Properties > Advanced system settings > Environment Variables.
  • Edit the Path variable in the System Variables section.
  • Add the following paths:
    • D:\MiniConda
    • D:\MiniConda\Scripts
    • D:\MiniConda\Library\bin
  1. Create the Environment in the Desired Directory:
  • Open Command Prompt and navigate to the installation directory, e.g., D:\ChatRTX:
cd /d D:\ChatRTX

Create the environment:

conda create --prefix ./env_nvd_rag python=3.10
  1. Re-run the Installer:
  • Navigate to the directory where the ChatRTX installer is located.
  • Run the installer and select the directory D:\ChatRTX where the environment was created.

This process should help in resolving the installation issue.

This tutorial seems success, but it still can’t instal whisper dan mistral. Please healp.

Chatrtx failed