Choopy Desktop Capture using Pipewire and OBS Studio 30.0.2 on Wayland

Hello there, when attempting to record your screen using OBS Studio 30.0.2 and Pipewire Desktop Capture results in an extremely choppy and laggy recording. The desktop it self is fine.

I attached a video recording a 3rd display using a capture card and pipewire to better visualize the issue.

Driver: 545.29.06
Desktop: Gnome 45.3 / Wayland
Kernel: 6.6.10
OS: openSUSE Aeon
OBS Studio: 30.0.2 (older versions had this issue as well, in fact I don’t know a version which worked)

nVidia Bug report:
nvidia-bug-report.log.gz (909.0 KB)

Running driver 550.40.07 it gotten better but still it has a lot of frame drops in the capture. Desktop itself is fine.

nvidia-bug-report.log.gz (1021.1 KB)

Gnome 45.3
Kernel 6.7.2-1-default
PipeWire: 1.0.2

Applications running in any form of fullscreen do not get updated in the capture at all:

My guess is it has something to do with Mutter redirecting fullscreen windows directly onto the screen instead of compositing them.

Yep, with the Gnome extention Disable unredirect fullscreen windows the capture does no longer skip fullscreen applications:

Driver: 550.54.14
OBS Studio: 30.0.2
PipeWire: 1.0.3

Desktop capture still choppy. In fact unchanged from what could be observed on 550.40.07. At least it didn’t got worse.

Probably a long shot, but if you specify the env variable export __GL_YIELD=USLEEP does it fix the issue ?
I have that specifically set for kwin(in /etc/profile.d/kwin.sh) and it has been working super good.

Thank you for the suggestion.
I added this to my .bashrc and rebooted but it did not helped.

1 Like