Chopper Demo show back screen when running GTX960m

Hello good people of the inter-webs

I’m having an issue running the compiled chopper demo.

basically all i see is a black window.

i can see the command line window, it print out the following

"loaded glew
initialized OpenGL basis
vsync: on
initializing Devices
found 1 device
Device ID : 000000073DAD0B40
info : Texture loaded.
info : Floating pint texture loaded "

the demo appears to be doing something as i can see the time (in millisecond) changing in the window title. and i can disable / enable vsync.

but the window is completely black, like its not rendering a thing, not an electronic sausage.

has any one had similar issues?

if there a fix/workaround?

or am i doomed?

I think some more informations would be beneficial. For example, which OS you are using, whether other Vulkan samples worked, which driver version you are using.

I have an GTX960 running on Ubuntu 15.10 64 bit using the 355.00.27 driver with beta vulkan support. Other Vulkan samples from LunarG worked like a charm, but the chopper Demo kept being black. After debugging it I came to the conclusion it’s the same issue as https://devtalk.nvidia.com/default/topic/917790/vulkan/bug-nvidia-linux-vulkan-drv-has-issues-with-xlib-vulkan-ext-/ which is already investigated by the nvidia team.

So no you are not doomed, Vulkan support is still in a beta state ;)

Hmmm, in in the current beta driver, the Mobile GPUs are appereantly not supported yet, so maybe that’s the real issue? So the most interesting question for your case would be, whether other Vulkan samples work on your machine.

https://devtalk.nvidia.com/default/topic/917680/vulkan-driver-installation-cannot-find-compatible-graphics-hardware/#4810852

Please see the sticky post: https://devtalk.nvidia.com/default/topic/918559/vulkan/nvidia-vulkan-samples-and-optimus-based-laptop-gpus/