Codeworks Android NDK install error [solved]

I installed codeworks, and every package I selected installed fine.
The Android NDK however (in the Android Toolchain category) failed to install because it can’t access some dll that (as I understand) it created/unpacked for itself.
Now this seems quite messy, so I’ll write the exact error message:

Error

Installing Android NDK 12b failed.

Return Code: 2
open
D:\Codeworks\android-ndk-r12b\prebuilt\windows-x86_64\lib\python2…\libpython2.7.dll.a:
Access is denied.

[OK]

As I found out, the … is “python2.7\config”
I have admin rights.

What i tried:
-re download the zip file
-tweak some access rights for users
-deleting the file

when I deleted the file, at the next install it gave a similar error message, but with a different file. It was a similar named file, but not in the lib folder, but some other sub folder of the windows-x86_64\bin…something

-So I deleted that file, and it gave me the first error message again.sigh

As I was writing this post, I again tried to delete the first file, and it somehow worked.

I’m posting this for people who might come across similar issues in the future, I resolved this problem already.

I had a similar problem installing on Debian Stretch, but in my case the NDK install failed due to local.cfg being read-only!?!

My solution was to de-select the NDK install to allow installation to succeed.
Once installed I could run the NVPACK/Chooser program and select the NDK for installation.
Installation succeeds from this route.