Command nvidia-smi on Jetson Nano not working?

Hello,

The nvidia-smi command on my Jetson Nano isn’t working, telling me the command is not found. Do I have to install some driver or how can I get it to work?
And, when I’m already asking: Is the Cuda Toolkit and cuDNN on the Jetson Nano already installed and configured or do I have to do it myself?

Thanks for the help in advance!

Hi @nemestomi2,

I think nvidia-smi is only available for Desktop GPUs. For Jetson boards you can use tegrastats, for example:

sudo ./tegrastats

Did you use the pre-built SD card image and followed this Getting Started with Jetson Nano guide from NVIDIA? https://developer.nvidia.com/embedded/learn/get-started-jetson-nano-devkit

You can also use the Nvidia SDK Manager to install CUDA and its dependencies.

Regards,
Fabian

Thanks @fabian.solano for the suggestion!
The only file I found was in /usr/bin and does not print the info I’m looking for. I’m looking for the architecture version of the GPU.
Yes, I use the prebuilt image exactly as described in the Getting Started guide and have CUDA 10.0 already installed. I just wanted to be sure I have those packages, too, because I don’t know wether they come together with CUDA or I have to install them manually. So are they installed on Jetson Nano already?

You can get the architecture version of the GPU from the following page https://developer.nvidia.com/cuda-gpus in the CUDA-Enabled Jetson Products tab

Nano is “-gencode arch=compute_53,code=sm_53”.