Communication Issue with Pixhawk 6C Telem2 and Jetson TX2

Greetings to the Jetson TX2 community!

I am reaching out to seek assistance with a communication issue between the Pixhawk 6C Telem2 port and Jetson TX2 on the Orbitty Carrier Board. I have followed the wiring configuration as mentioned in the PX4 discussion forum (Pixhawk 6C Telem2 Communication Issue with MAVROS - ROS / MAVROS / MicroDDS - Discussion Forum for PX4, Pixhawk, QGroundControl, MAVSDK, MAVLink), but unfortunately, I am facing problems.

The connection setup I have tried is as follows:

  • Pixhawk Telem2: RX → Jetson TX2: TX
  • Pixhawk Telem2: TX → Jetson TX2: RX
  • Pixhawk Telem2: GND → Jetson TX2: GND

Regrettably, this connection did not establish the expected communication. However, when I resorted to using a USB-TTL adapter and connected it to the USB port of the Jetson TX2, the communication worked perfectly.

In addition, I encountered a peculiar situation where attempting to use the UART0 port on the Orbitty Carrier Board led to a reboot loop of the Jetson TX2, and it failed to initialize until the UART0 connection was disconnected.

I kindly request the support and guidance of the Jetson TX2 community in resolving this communication issue between the Pixhawk 6C Telem2 port and Jetson TX2 on the Orbitty Carrier Board.

Thank you in advance for your kind assistance and valuable insights!

We don’t have much experience about the device. Would see if other users can give suggestion.

The latest release for TX2 is Jetpack 4.6.3. Not sure if the SDK has to fit specific Jetpack version. May confirm the versions are matched.

I want to add something which might be related, but perhaps not: Third party carrier boards usually have a different device tree. Jetsons have many pins which have different alternate functionality, and device tree is how those pins determine their function. Unless that carrier board is an exact match to the layout of the developer’s kit carrier board (a few are, many are not), the device tree would have to be from the manufacturer’s (the carrier board’s) device tree. Having such an odd behavior makes me wonder if that’s an issue. Have you ever flashed without using the Orbitty manufacturer’s software? If so, this is suspect.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.