Compatibility for Raspberry Pi Camera-Module V2.1?

Hello there,

I’m just setting up my Jetson Nano and everything has worked fine until now. I followed the guide https://www.pyimagesearch.com/2019/05/06/getting-started-with-the-nvidia-jetson-nano/ so far and got stuck by the Jetson Inference models. I try to run GoogleNet (imagenet-camera) as described with my Raspberry Pi V2.1 camera. At first, it’s initializing the device:

[gstreamer] gstCamera successfully initialized with GST_SOURCE_NVARGUS, camera 0

imagenet-camera:  successfully initialized camera device
    width:  1280
   height:  720
    depth:  12 (bpp)


imageNet -- loading classification network model from:
         -- prototxt     networks/googlenet.prototxt
         -- model        networks/bvlc_googlenet.caffemodel
         -- class_labels networks/ilsvrc12_synset_words.txt
         -- input_blob   'data'
         -- output_blob  'prob'
         -- batch_size   1

But then, the following happens:

imagenet-camera:  camera open for streaming
Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp,
execute:521 No cameras available

In this state, it keeps stuck forever. I read that the Raspberry Pi V2 camera is compatible with the Jetson Nano, but does the same apply for V2.1? Is it possible that this is causing the error and if not, what is it then?

Thanks for the help in advance!

Did you build the kernel image to include you sensor DT.
Try the gstreamer(nvgstcapture-1.0) pipeline to verify the sensor driver on your system first.

Hello again,

Thanks for the reply, the only problem is that every time I try to use the nvgstcapture-1.0 pipeline, the same error occurs as above:

===== NVMEDIA: NVENC =====
NvMMLiteBlockCreate : Block : BlockType = 4 
H264: Profile = 100, Level = 40 
Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp,
execute:521 No cameras available

Then it freezes again. How can I build the kernel image you talked about?

Have a check this document.

https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%2520Linux%2520Driver%2520Package%2520Development%2520Guide%2Fcamera_sensor_prog.html%23