compilation fails with 'TERMINATED by signal 11'

Hi,

i’ve tried with two platform this week in order to profile if pgi works fine with latest 2.6 kernel and specific program we interested (used to 2.4 before, with RH7.3), however, compilation fails with the following error msg when dealing with one of the routine:


/usr/local/pgi/linux86/6.0/bin/pgf90 -c -fast -Knoieee -Mdalign -byteswapio -Mcache_align -pc 64 -DX11 -DPGI -Dmachine_linux86 -Dplatform_x11 -Dclock_etime -I…/… batom_hamil_mod.F90
pgf90-Fatal-/usr/local/pgi/linux86/6.0/bin/pgf901 TERMINATED by signal 11
Arguments to /usr/local/pgi/linux86/6.0/bin/pgf901
/usr/local/pgi/linux86/6.0/bin/pgf901 batom_hamil_mod.F90 -opt 2 -terse 1 -inform warn -nohpf -nostatic -x 119 0x100000 -x 19 0x400000 -x 59 4 -x 15 2 -x 49 0x400004 -x 51 0x20 -x 57 0x4c -x 58 0x10000 -x 124 0x1000 -x 57 0xfb0000 -x 58 0x78031040 -x 70 0x6c00 -x 48 3328 -stdinc /usr/local/pgi/linux86/6.0/include:/usr/local/include:/usr/lib/gcc/i386-redhat-linux/3.4.3/include:/usr/lib/gcc/i386-redhat-linux/3.4.3/include:/usr/include -def unix -def __unix -def unix -def linux -def __linux -def linux -def inline= -def i386 -def __i386 -def i386 -def __NO_MATH_INLINES -def linux86 -def __THROW= -idir …/… -def X11 -def PGI -def machine_linux86 -def platform_x11 -def clock_etime -preprocess -freeform -x 125 2 -vect 48 -quad -x 119 0x10000000 -output /tmp/pgf90aaaaamioaf.ilm
make: *** [batom_hamil_mod.o] Error 127


should i turn to latest version of pgi?, say 6.0-8, or?

since i wont have same problem either with 2.4 or 2.6 kernel on which old pgi compiler was installed, say 5.2

any suggestion? Thanks

BR,
J

Hi J,

This is a serious error. Can you please either send a report to trs@pgroup.com along with this and any dependent files or post them so I can download them? Hopefully, the bug has already been reported and fixed in either release 6.0-8 or 6.1-1. If not, well need to have it investigated and fixed. We’ll also see if there is a work around once we determine what’s causing the problem.

Thanks,
Mat

Hi Mat,

i am trying 6.0-8 now, and will let you know if bug remains, otherwise, i’ll turn to the trs instead, in which all needed includes, objects as well as source will be deliveried.

btw, i didnt know 6.1.1 already downloadable there in archive? or will this released soon?

thanks for your prompt reply.

BR,
J

Hi Mat,

unfortunely, the same bug exist in latest release i can reach, say 6.0-8, and i’ve send the test suite to trs with same title as here.

Thanks for your help, i am looking forward if this could be resolved.

Br,
J

Hi Mat,

i just tried the 6.1.1 which release couple of days ago, and the bug remains, i still have prob compiling the code with same error msg.

will wait update from trs then. :-)

BR,
J

Hi Jason,

In looking a the notes for TPR3697 it looks like one of our engineers has been able to fix the problem and the fix should appear in the next minor release (6.1-2) due at the beginning of February.

Hope this helps,
Mat