Compilation of CUDA Samples misses nvrtc.h

Hi all,

I flashed the most recent Jetpack 2.2 with a full install to the Jetson TX1. After the installation it looks like the samples were built correctly whilst the installation procedure (CUDA 7.0.76).

While getting to know the platform I ran “make clean” for the NVIDIA_CUDA-Samples and wanted to do a “make all” afterwards. However, the compilation now misses the nvrtc.h file referenced from nvrtc-helper.h (which is there). This file is indeed missing on the system. The host from where I flashed (and not deleted) the Jetpack files has the nvrtc.h but only in the /usr/local/cuda-7.0/targets/x86_64-linux/include folder, but nowhere else (especially not in the aarch64 folder).
I tried the workaround from the release notes pdf (which should not really be related but anyway) to no avail.

May it be that NVRTC is not supported on aarch64? Do I need to use another makefile?

EDIT: After more investigation: Whilst the Jetpack installation the CUDA samples are cross-compiled on the host. Does that mean, that CUDA software cannot be developed on the Jetson itself but needs to be cross-compiled and copied over?


Hi waterjet,

We’re investigating this issue, the status will be updated once we clarified it.


Any update on this?

Citing a PM I received: