compilation pb while porting from linux to maxos


I am new to cuda and just trying to compile code I got from an collaborator who has been coding under linux.

I am working on a MacBookPro, MacOS 10.5.2, GeForce 8600M GT and I also tried on a MacPro, MacOS 10.5.2 without a cuda enabled card. I just downloaded the toolkit and the sdk. I was able to compile all the examples in the SDK and all the tests seem to be working fine.

While compiling the cuda code written under linux I run into the following pb:

gives the following errors:

Does anybody have a clue about what could cause these errors? I get the same errors for both configurations above.

Thanks Christian

I have a similar problem. Looks like NVCC on OSX is not generating cubin files the same as the linux version. Our code builds fine under FC7, but fails with those exact same “new” operator complaints on OSX.

You manage to get anywhere on this?


Update: I isolated my problems to the use of stl::vector from within a cu file. This works under linux but not OSX (Cuda 1.1 beta).


I know this is old but using the newest 3.0 beta I still get the same problem. I want to compile some code written under linux and get the above type of errors.