Computeprof error


I’m experiencing the error

when trying to run computeprof with the OpenCL SDK examples. The CUDA examples on the other hand work flawlessly. Running the OpenCL examples in the terminal by setting the environment variables CUDA_PROFILE=1; CUDA_PROFILE_CSV=1 does not provide any output file, while it does with the CUDA examples.

My setup:

  • Mac Os X 10.6.4 (Processor: 2.4 Ghz Intel Core 2 Duo / Memory: 4GB 1067 MHz DDR3 / Graphics: NVIDIA GeForce 9400M)

  • Cuda Toolkit 3.2.8

  • GPU Computing SDK 3.2

  • Devdriver 3.2.8


I am experiencing the exact same issue.


I am experiencing the exact same issue.

me too, on Ubuntu 10.10.

How did you solved the problem?

I’m having the same problem. Now I’m trying with version 3.2 of the NVIDIA toolkit (tried also with older versions) and I always get

Profiler data file '…temp_compute_profiler_0_0.csv for application run 0 not found

I can run the application to profile in terminal.

Anybody has any idea?

I think there are two problems to distinguish.

On MacOS, the only OpenCL platform I know of is Apple’s, so despite it has surely been developed in cooperation with NVIDIA, this is not the same NVIDIA OpenCL implementation as on Linux or Win. I’d be glad to hear something else, but personally I never got computeprof + OpenCL working on MacOS.

From what I read, one should use OPENCL_PROFILE=1 or better COMPUTE_PROFILE=1 now, but I’m not sure if it really makes a difference. Another common problem is that people forget to release their OpenCL objects explicitly - only then a log file is written.

I thank you for your quick response. I reviewed my code and didn’t found any recources that where not released. To be sure I have also tried to profile the example applications (oclDotProduct and oclBandwidthTest) ut I still get the same results. I tried a lot of combinations of the environment variables by setting them in the Visual Profiler Application (is this the same as from commandline?).

I’m using linux btw.

Any suggestions what I can try out?