Connect IP camera to a Jetson device

Hi everyone,
I’m trying to connect an IP camera to my Jetson nano device.
The camera information is:
brand: Dahua
model: IPC-HDW1230T1-S4

I’m trying the following gstreamer command.

$ gst-launch-1.0 rtspsrc location=rtsp://user:password@192.168.1.108:554 ! fakesink

But I get the error:

Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Progress: (open) Opening Stream
Progress: (connect) Connecting to rtsp://admin:12345678W@192.168.1.108:554
Progress: (open) Retrieving server options
Progress: (open) Retrieving media info
ERROR: from element /GstPipeline:pipeline0/GstRTSPSrc:rtspsrc0: Could not open resource for reading.
Additional debug info:
gstrtspsrc.c(5829): gst_rtspsrc_setup_auth (): /GstPipeline:pipeline0/GstRTSPSrc:rtspsrc0:
No supported authentication protocol was found
ERROR: pipeline doesn't want to preroll.
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...

I have been reading similar topics in the forum but non of them have worked for me so far, maybe is the camera brand.

Could someone help me make it works.
Thanks a lot.

You may try to remove gstreamer1.0-plugins-ugly if installed

Hi,
I just removed it. Still getting the same error.

As per Dhauva the URL is not right I think… Pls check the URL to be used from Dhauva

1 Like

Hi @techguyz,
yes, you are right! for Dahua the URL have to be rtsp://admin:password@192.168.1.108:554/cam/realmonitor?channel=1&subtype=1

Thank you.

Sorry, I think now the URL is fine, but I still getting the same error with the command:
$ gst-launch-1.0 rtspsrc location=rtsp://admin:password@192.168.1.108:554/cam/realmonitor?channel=1&subtype=1 ! fakesink

Hi,
You may check if the URI can be opened in VLC player. Or clean the cache and try again:

$ rm .cache/gstreamer-1.0/registry.aarch64.bin

Hi,
The URI can be opened in VLC player from my laptop.
I cleaned the cache but still with the same error and no display of the videostream:

Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Progress: (open) Opening Stream
Progress: (connect) Connecting to rtsp://admin:12345678W@192.168.1.108:554/cam/realmonitor?channel=1
Progress: (open) Retrieving server options
Progress: (open) Retrieving media info
ERROR: from element /GstPipeline:pipeline0/GstRTSPSrc:rtspsrc0: Could not open resource for reading.
Additional debug info:
gstrtspsrc.c(5829): gst_rtspsrc_setup_auth (): /GstPipeline:pipeline0/GstRTSPSrc:rtspsrc0:
No supported authentication protocol was found
ERROR: pipeline doesn't want to preroll.
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...

Hi,
It might be an issue in rtspsrc plugin. Could you please go to gstreamer forum:

Since it is a native plugin, users in the forum may have more experience to share suggestion.

Ok, I will take a look, thank you.

Hi DaneLLL,
I solved this problem by placing double quotes “” in the URI string, like this:

gst-launch-1.0 rtspsrc location="rtsp://admin:password@192.168.1.108:554/cam/realmonitor?channel=1&subtype=1" ! fakesink

the problem had to do with “&” as a special character in the URI string.

Thank you

1 Like