Connect Jetson nano with IP camera

I tried to connect an IP camera to my Jetson nano device using gstreamer command.

Here is the information of camera
brand: Dahua (4MP camera)
model: DH-IPC-HFW2439SP-SA-LED-0360B-S2

For the hardware setup, I provided power for the camera by connecting the camera with PoE switch through ethernet cable. Then I used another ethernet cable to connect PoE to Jetson nano.

Here is the Gstreamer command I used

$ gst-launch-1.0 rtspsrc location=“rtsp://user:password@” ! fakesink

But I got this error.
I tried to solve the error with the similar topics in this forum but it didn’t work for me.

Setting pipeline to PAUSED …
Pipeline is live and does not need PREROLL …
Progress: (open) Opening Stream
Progress: (connect) Connecting to rtsp://user:password@
ERROR: from element /GstPipeline:pipeline0/GstRTSPSrc:rtspsrc0: Could not open resource for reading and writing.
Additional debug info:
gstrtspsrc.c(7469): gst_rtspsrc_retrieve_sdp (): /GstPipeline:pipeline0/GstRTSPSrc:rtspsrc0:
ERROR: pipeline doesn’t want to preroll.
Setting pipeline to PAUSED …
Setting pipeline to READY …
Setting pipeline to NULL …
Freeing pipeline …

I would appreciate if you could help.

Duplicated with Connect IP camera to Jetson Nano - Jetson & Embedded Systems / Jetson Nano - NVIDIA Developer Forums

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.