Connectx-6 VPI not appearing as an Ethernet device on Linux ??

It may seems a dumb question, but we’re trying to use a connectx-6 VPI card to a 100 Gb/s Ethernet switch under centos 7.7, the adaptor is only seen as an infiniband device, but not an Ethernet one. modprobe mlx4_en does nothing. Tried with centos drivers, OFED drivers, base centos kernel 7.7 , elrepo kernels, even debian distribution.

Tried with mlxconfig to change the port type LINK_TYPE_P1, but it’s not possible with this card. Also flashed last firmware.

Device Type: ConnectX6

Part Number: 0Y1T43_07TKND_Ax

Description: ConnectX-6 VPI; 100Gb/s (HDR100; EDR IB and 100GbE); single-port QSFP56; PCIe3.0 x16 Adapter

PSID: DEL0000000013

PCI Device Name: 0000:3b:00.0

Base GUID: 1c34da0300505e30

Base MAC: 1c34da505e30

Versions: Current Available

FW 20.26.4300 N/A

PXE 3.5.0805 N/A

UEFI 14.19.0017 N/A

We previously used connectX-4 cards without issues, we probably lack experience with these new models…

Is there something obvious I’m missing ?

Hello Yann,

Thank you for posting your issue on the Mellanox Community.

Based on the information provided and the information from the f/w release notes, we had an internal sync. regarding the current capabilities of this Dell OEM Mellanox Connect-X 6 VPI adapter.

Based on the current f/w 20.26.4300, this adapter is currently only capable of InfiniBand. The Ethernet capability will be available in the upcoming Dell OEM f/w 20.27.xxxx. Currently Dell is certifying this f/w. For availability, please reach out to Dell Support.

The information provided in the current f/w header and RN is not correct, and will be corrected.

For further information regarding the capabilities specific for the Dell OEM Mellanox ConnectX-6 adapter, please reach out to Dell Support.

Thank you,

~Mellanox Technical Support

Oh ! Thank you very much, it explains a lot… Will wait for the new firmware.