No link w/ ETH mode in W10 Pro on Connectx-2 dual QSFP+ VPI DDR/20Gbps Infiniband (IB/Eth) MHRH2A-XSR

I know CX-2’s aren’t supported anymore but I’ve acquired about a dozen of them for testing.

I have myself two machines with dual QSFP+ CX2’s (MHRH2A-XSR) that can connect together via a 1M passive Arista QSFP+ DAC when running in IB mode and opensm/the subnet manager running. But when I switch them to ETH mode they stay disconnected with no LED link lights.

Running the latest drivers “5.50.1474.0” with firmware 2.9.1810. But have also tried 5.35 5.10 4.2
and even tried firmware 2.10.720. On every restart, I get an “Error” msg in windows eventvwr for system: “Failed to initialize Mellanox ConnectX-2 Ethernet Adapter.” and then it leaves them disabled in device manager (but can re-enable them)

but also this error “Native_7_0_0: Execution of FW command failed. op 0x9, status 0x8, errno -12, token 0x3d00, in_modifier 0x2, op_modifier 0, in_param 0.”


The last WinOF version that supports ConnectX-2 cards is 4.80.
You can take it from here:

Under Archive.
Also, how are you trying to switch it to Eth mode?
First, check that this is indeed a VPI card that can work also in Eth mode.

Best Regards,