Flashed wrong firmware? MHRH2A-XSR

I recently bought a ConnectX-2 MHRH2A-XSR Card with the Intention to use it as a 10 GbE NIC. At first i was not able to get the Card or one of its Ports to work in Ethernet mode. Not realising at the time it was probably a driver problem (The newer OFED versions dont seem to support such old cards anymore), I tried to update the formware. On the official Firmware Download page I only saw a firmware for the MHRH2A-XTR. But I did read in a random forum, that the “T” only stands for “tall bracket” and the “S” for “short bracket”. That is why i just flashed the MHRH2A-XTR onto my card. Now I cant get the card to work in eth mode at all. I tried at least 5 OS (Debian, Ubuntu, windows in different versions) with different driver versions, but no matter what I try, the card wont work in eth mode. In Linux I get some type of “firmware error” after which the specified port is unusable and in windows almost the same behavior.

Now: Could flashing the (slightly) wrong firmware be the problem? And if yes where do I get the right Firmware now?

(Of course i wasnt smart enough to pull backup first…)

Hello Moritz,

Thank you for posting your inquiry on the NVIDIA Networking Community.

The ConnectX-2 is an adapter which is EOL and EOS for a long time already. We recommend to move to a more recent adapter, for example ConnectX-4 or ConnectX-5

I found the latest f/w version for your adapter. You can download through the following direct download link → https://content.mellanox.com/firmware/fw-ConnectX2-rel-2_9_1810-MHRH2A_A2.bin.zip

This firmware is for the following PSID:

mstflint -i fw-ConnectX2-rel-2_9_1810-MHRH2A_A2.bin q full

Image type: FS2

FW Version: 2.9.1810

MIC Version: 1.5.0

Device ID: 26418

Description: Node Port1 Port2 Sys image

GUIDs: 0002c9000100d050 0002c9000100d051 0002c9000100d052 0002c9000100d050

MACs: 0002c9000001 0002c9000002

VSD: n/a

PSID: MT_0F90120008

As this is an older adapter, configuration of the port for IB and Ethernet needs to be done through the ‘connectx_port_config’ utility.

You can use the following link as reference → https://sources.debian.org/src/ofed-docs/1.4.2-1/mlx4_release_notes.txt/

Thank you and regards,

~NVIDIA Networking Technical Support

Hi!

Thank you for your answer!

I successfully flashed the new firmware onto the card. However I am not able to change the port type to eth on the card. I tried both the mlnx-en and the ofed driver, however both of them still produce this error:

[ 961.669548] mlx4_core 0000:04:00.0: command 0x9 failed: fw status = 0x8

[ 961.669593] mlx4_en: 0000:04:00.0: Port 2: Failed Initializing port

I used the 4.9 LTS version for both drivers. I am starting to think that there is something physically wrong with this card. My card does not appear in the mlx4 release notes as one of the unsupported cards but it produces the given error anyway.