Crash (probably of X11) after I enter with the mouse into a scaled VirtualBox machine

if I try to boot a Linux VirtualBox VM which is scaled (more than 100%), I get an immediate crash, probably of X11, and I get back to the login. I see that these errors can be seen in dmesg:

[60048.696281] NVRM: GPU at PCI:0000:01:00: GPU-a048e6ea-3105-7b75-ca04-b034f8a1ea19
[60048.696288] NVRM: Xid (PCI:0000:01:00): 32, pid=263, Channel ID 00000008 intr1 00000008 HCE_DBG0 0000124c HCE_DBG1 90808180
[60048.696533] NVRM: Xid (PCI:0000:01:00): 32, pid=1291, Channel ID 00000008 intr1 00000008 HCE_DBG0 0000124c HCE_DBG1 a6737472
[60057.503506] EXT4-fs error: 186 callbacks suppressed
[60057.503508] EXT4-fs error (device sda1): ext4_wait_block_bitmap:517: comm ACPI Poller: Cannot read block bitmap - block_group = 5, block_bitmap = 1030
[60057.503517] fbcon: Taking over console
[60057.503545] EXT4-fs error (device sda1): ext4_discard_preallocations:4093: comm ACPI Poller: Error -5 reading block bitmap for 5
[60057.515778] Console: switching to colour frame buffer device 240x67
[60257.715152] vboxdrv: 0000000000000000 VMMR0.r0
[60258.843547] vboxdrv: 0000000000000000 VBoxDDR0.r0
[60258.921424] vboxdrv: 0000000000000000 VBoxEhciR0.r0
[60258.923472] VMMR0InitVM: eflags=246 fKernelFeatures=0x0 (SUPKERNELFEATURES_SMAP=0)
[60284.311962] NVRM: Xid (PCI:0000:01:00): 31, pid=35914, Ch 00000009, intr 10000000. MMU Fault: ENGINE GRAPHICS GPCCLIENT_PROP_0 faulted @ 0x1_30210000. Fault is of type FAULT_PTE ACCESS_TYPE_WRITE
[60284.541303] NVRM: Xid (PCI:0000:01:00): 32, pid=35914, Channel ID 00000008 intr 00040000
[60284.541481] NVRM: Xid (PCI:0000:01:00): 32, pid=35914, Channel ID 00000008 intr 00040000
[60284.541604] NVRM: Xid (PCI:0000:01:00): 69, pid=35914, Class Error: ChId 0008, Class 0000b097, Offset 000001b0, Data 20040004, ErrorCode 0000000c

Is this related to the nVidia driver? Any idea why?
Thank you.nvidia-bug-report.log (930.9 KB)

Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).

I attached the log. It still is a compressed file, I just renamed it.

That’s a lot of different errors in the logs, the system seems to have been up for a long time, being in suspend maybe meanwhile. There’s also an unrelated vbox segfault, the drive /dev/sda1 has been remounted ro due to disk error and then there were different XIDs from the nvidia driver. Unfortunately, the Xorg logs from the crash weren’t included, were already overwritten by the time you created the log.
In general, there’s a known bug with the modesetting driver on Optimus setups leading to Xorg crashing when the cursor-size is larger than 64. Scaling adds to the size.
The previous vbox segfault and XID 32 might be related to faulty system memory.
The ext4 crash points to defective harddisk.
If the xorg crash is related to the cursor bug, this can be worked around by either disabling scaling or setting a smaller cursor-size.
In any case, you should thoroughly check your complete hardware.

there was probably too much noise in those logs. I rebooted the system, reproduced the issue and immediately created the logs. /dev/sda is a external HD, I created another VM in my internal memory to remove a variable. Nothing changed.
I also tried to change cursor size to 16. Nothing changed.

Note that this issue immediately disappears if I disable nVidia from the nVidia settings and only run on Intel HD. Everything works properly then.

Also I should probably say that this issue is something I always experienced, it just changed a bit recently. As soon as scaling is changed in VirtualBox, the machine freezes and fans start spinning. In the past, the machine remained freezed forever, now there is a short freeze, and X11 crashes, making the system available again.

nvidia-bug-report_2.log (346.9 KB)

Now there’s the backtrace from the nvidia DDX visible as well as XID 32 kernel driver messages at the same time. Do you use 3D gpu accel for the VM?

I guess you are talking about the checkbox “enable 3D acceleration”. That is not checked. The controller selected is VMSVGA.
Thank you for your help.

nVidia driver version 450.57 seems to fix the issue.