Cross Compile QT for Jetson Nano Problem

I am trying to cross compile Qt for Jetson Nano. I configured the build with these parameters:

../qt-everywhere-src-5.15.1/configure -opengl es2 -device linux-jetson-nano  -device-option CROSS_COMPILE=/opt/qt5jetson/gcc-linaro-7.5.0-2019.12-x86_64_aarch64-linux-gnu/bin/aarch64-linux-gnu- -sysroot /opt/qt5jetson/sysroot -prefix /usr/local/qt5jetson  -opensource -confirm-license -skip qtscript -skip wayland -skip qtwebengine -force-debug-info -skip qtdatavis3d -nomake examples -make libs -pkg-config -v

when I tried to run make command I got error like below. I can’t find solution for this problem.

final link failed: Bad value
collect2: error: ld returned 1 exit status
Makefile:1227: recipe for target '../../lib/' failed
make[3]: *** [../../lib/] Error 1
make[3]: Leaving directory '/opt/qt5jetson/qt5build/qtbase/src/corelib'
Makefile:224: recipe for target 'sub-corelib-make_first' failed
make[2]: *** [sub-corelib-make_first] Error 2
make[2]: Leaving directory '/opt/qt5jetson/qt5build/qtbase/src'
Makefile:50: recipe for target 'sub-src-make_first' failed
make[1]: *** [sub-src-make_first] Error 2
make[1]: Leaving directory '/opt/qt5jetson/qt5build/qtbase'
Makefile:83: recipe for target 'module-qtbase-make_first' failed
make: *** [module-qtbase-make_first] Error 2"

How can I solve for this problem?

I am not a QT guy, and have not tried this compile. However, you should know that if ld failed, then your build was trying to link against a library somewhere, and the library was not found. Perhaps there is some system requirement library which needs to be added first. Or perhaps the library exists, but it isn’t in your linker path. Perhaps something else needed to be built first to create the library. I don’t know which library is missing, the message only says it was building without saying what link was being attempted. Perhaps there is some log content prior to this naming the file/library which is missing?

You may refer to the posts: