Crypto enabled/disabled blue field2

I am using the node with smartNIC on cloudlab. Here is the hardware description for it:
Device Type: BlueField2
Part Number: MBF2H516A-CENO_Ax
Description: Bluefield-2 SmartNIC 100GbE Dual-Port QSFP56; PCIe Gen4 x16; Crypto Disabled; 16GB on-board DDR; 1GbE OOB management; FHHL

It has crypto disabled.
I wonder whether that is from the hardware restriction like the smartNIC does not have the hardware accelerator or if there is a way to change it into a crypto enabled state.

Hi @cxinyic ,

Please refer to:

  1. https://docs.nvidia.com/networking/display/BlueField2DPUENUG/Specifications#Specifications-MBF2H516A-CEEOT/MBF2H516A-CENOTSpecifications
  2. https://docs.nvidia.com/networking/display/BlueField2DPUENUG/Introduction

“The BlueField-2 DPU crypto-enabled versions include a BlueField-2 IC which supports accelerated cryptographic operations. In addition to specialized instructions for bulk cryptographic processing in the Arm cores, an offload hardware engine accelerates public-key cryptography, and random number generation is enabled.”

Best Regards,
Chen

1 Like

Thanks for the information!

Regarding this, you can find more information on the topic at https://goit.global/ph/. It seems to be a discussion or update related to the activation or deactivation of crypto functionality in the blue field2’ system. Without specific context, it’s hard to determine the implications of this change. Users and stakeholders should closely review the provided link to understand the implications and rationale behind this decision. It’s crucial to stay informed and consider all aspects before forming any opinions. Transparency and communication are vital in such matters to ensure a smooth transition, if applicable.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.