Cannot enable NIC mode from DPU mode on Bluefield 2


I am trying to enable NIC mode from DPU mode on Bluefield 2, but I encountered the error that the device does not support these parameters: INTERNAL_CPU_PAGE_SUPPLIER, INTERNAL_CPU_ESWITCH_MANAGER, INTERNAL_CPU_IB_VPORT0, and INTERNAL_CPU_OFFLOAD_ENGINE.

My command and output are as below:


Device #1:

Device type:    BlueField2      
Description:    BlueField-2 DPU 100GbE/EDR/HDR100 VPI Dual-Port QSFP56; PCIe Gen4 x16; Crypto Enabled; 16GB on-board DDR; 1GbE OOB management; FHHL
Device:         /dev/mst/mt41686_pciconf0

Configurations:                                      Next Boot       New
-E- The Device doesn't support INTERNAL_CPU_PAGE_SUPPLIER parameter

If I exclude INTERNAL_CPU_PAGE_SUPPLIER=1 in my command, it would output that the device does not support other parameters including INTERNAL_CPU_ESWITCH_MANAGER, INTERNAL_CPU_IB_VPORT0, and INTERNAL_CPU_OFFLOAD_ENGINE.

I wonder what is the reason for this and how I can change from DPU mode to NIC mode on Bluefield 2. Thank you very much for your time and help!


Please make sure you have the latest GA DOCA and Firmware installed on the BlueField-2 device.
Also, please make sure the host has the latest MLNX_OFED installed.
You can find all of these on the NVIDIA Networking website: Firmware for NVIDIA BlueField-2 SmartNICs,,
Linux InfiniBand Drivers.

Once all versions are up-to-date and latest, please try again.
If you still encounter this issue, please open a case at:, and it will be handled according to entitlement.