Wrong credentials - Cannot access Bluefield via rshim

Hi, I have been using Bluefield for a while, but at some point, I cannot access it anymore through
ssh ubuntu@192.168.100.2

I got a permission denied error. I checked all my other interfaces and IP addresses and routing tables; there is no chance that I accidentally try to connect to some other machine on the LAN - I see the explicit entry in the output of route -n for interface tmfifo_net0.

I decided to reinstall ubuntu on the SmartNIC by explicitly setting a new password to be used. I followed this documentation: https://docs.mellanox.com/display/BlueFieldSWv36011699/Upgrading+NVIDIA+BlueField+DPU+Software#heading-SoftwarePrerequisites, more precisely the section Image installation.

Still, I cannot log in; I have the same permission denied error.

I also tried reinstalling the OS without the --config parameter as the documentation said; if it is missed, the system will ask me to change the password after the first login.
I ended up in the same situation.

As a last resort, I tried communicating to the Bluefield via the rshim0 console.
screen /dev/rshim0/console.
Credential is not working either: Login incorrect.

Can someone help me with this?

I believe this requirement to set a password at BFB install with --config changed in 5.3/3.6. It is now compulsory.

https://docs.nvidia.com/doca/sdk/installation-guide/index.html#image-installation

-jb

Okay, I got this working. It turned out that the system I was using (@Cloudlab) was also configured ifb interfaces for QoS purposes. I thought they might redirect my connection request to somewhere else, so I removed all of them by removing the kernel module itself:
rmmod ifb

After this, I was able to access Bluefield again, and as promised, it was asking for password change.
So, remove ifb devices if you have any, and I can confirm that --config is NOT compulsory; it works as intended.

I have written a post about the whole reinstallation process. If someone wants to do the same or has the same issue as I did, feel free to give it a read!