Installation Error: Cannot Create /dev/rshim0/boot

Hi new at this but following the sdkmanager cli guide it gives an error:

info: sudo bfb-install -bfb <file.bfb> --rshim rshim0 --config ./bf.cfig
error: sh: 1: cannot create /dev/rshim0/boot: Invalid Argument
info: failed to push BFB
info: sudo ifconfig tmfifo_net0 netmask up
info: waiting for response…

Timing out ofcourse, it can’t send the boot stream

Ubuntu 20.04 Host (fresh install), Bluefield BF2H322A

Hi TinkerFrank,

Thank you for posting your query on NVIDIA community.

I would like to inform that the command line used to run the command is incorrect. You will have to add the actual path of the BFB image that has been installed on the Host rather than using “<file.bfb>”. The < > are just to explain that needs to be added as a parameter for the -bfb flag.

You can download the appropriate BFB image from NVIDIA DOCA SDK | NVIDIA Developer
Please scroll down the page to the section " BlueField DPU Runtime and Driver Downloads" and click the “Bluefield Software” Tab.


I ommitted it because I had to type it over, tried again on 22.04 but same error :(

Some more info:

 lspci |grep BlueField
 10:00.0 Memory controller: Mellanox Technologies MT42822 Family [BlueField-2 SoC Flash Recovery] (rev 01)*

which according to: Mellanox Interconnect Community, indicates: “If the lspci output of the HCA shows “Flash Recovery”, this means that the flash is empty or the FW in the flash does not work.”
But the whole point is that I am trying to flash using rshim0 but doesnt work, is there another way?

Hi, I wrote a couple of blog posts about using Bluefield. I have also reinstalled the firmware several times. You might have a look at Part V of my blog series on how to do that.

1 Like