Csr_pcie5r1: EMEM address decode error for NX

Hello everyone:
When I use jetson Xavier NX, it starts from SSD. I don’t know if this printing will affect my system or application. I don’t understand where this error is caused, and what impact will it have?
[ 21.890775] mc-err: (255) csr_pcie5r1: EMEM address decode error
[ 21.890928] mc-err: status = 0x200640ef; addr = 0xffffffff00; hi_adr_reg=ff08
[ 21.891058] mc-err: secure: yes, access-type: read
[ 21.891158] mc-err: mcerr: unknown intr source intstatus = 0x00000000, intstatus_1 = 0x00000000
[ 21.891179] t19x-arm-smmu 12000000.iommu: Unhandled context fault: smmu1, iova=0x4fd54b000, fsynr=0x80003, cb=1, sid=91(0x5b - PCIE5), pgd=270500003, pud=270500003, pmd=249e81003, pte=0

sys.log (64.8 KB)

Which jetpack version in use? Custom board or devkit?

Have you figured out which device is causing this ?

The development kit is used, and the official image system is installed. Version is NVIDIA Jetson Xavier NX Developer Kit - Jetpack 4.6 L4T 32.6.1.
I don’t know exactly what caused this error, I connected three cameras, one USB camera, two CSI cameras, and used opencv to drive them, but in my opinion this error is already when the system starts happened.

Then please try with new jetpack release first.

Also, try to remove all peripherals especially pcie devices on your side to confirm what you said is correct.

Okay, I’ll try updating the latest firmware to see if this resolves the issue

Hi, I tried to install the latest jetpack, and now I am using version 5.1. After the installation, it seems that there is no mc-err error, but it seems to cause a kernel problem. I am not sure whether this is a kernel crash.

log.txt (66.4 KB)

Seems related to ethernet and not related to original issue.

Yes, I updated the new version, which may have solved the problem at the beginning, but it caused a new situation, which did not appear in the previous version.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.