CUDA 10.0 and nvidia-418 driver on Ubuntu 14.04


I have a system with Ubuntu 14.04 (I know it’s very old, but it’s supposed to be still supported by both Ubuntu and Nvidia), a GeForce GTX 960 (connected to the screen) and a Titan Xp.

In an effort to update from CUDA 8.0 to 10.0 (version 10.0.130-1 in particular), I got a black screen at startup and then failure to recover lead to two re-installations of the system. As a result, I found that nvidia-418 driver (version 418.87.01 in particular) was causing the problem, with or without CUDA, on a number of Linux kernels including 3.13.0-170-generic (the current one), 3.13.0-169-generic and 3.13.0-32-generic (on a fresh Ubuntu 14.04 without anything else installed). This is not happening with nvidia-410 (the current one) or any previous driver I was using for the last few years. It is happening however on the same system with the Nouveau driver.

nvidia-418 driver is a dependency of CUDA 10.0. Switching back to nvidia-410 uninstalls CUDA 10.0, and I am not sure what is situation with earlier versions of CUDA. Although I have not tried to install, CUDA 10.1 should not be any different because it brings the same driver, version 418.87.01. I guess that sooner or later in some system update, I would have the same issue without CUDA at all. Questions:

  1. Is there a known issue or fix related to nvidia-418 driver on Ubuntu 14.04?
  2. Can it be an issue with the GeForce GTX 960?
  3. Is it possible to install CUDA 10.0 or later without updating to nvidia-418?


Get the system running with the 410 driver.

Then install:

sudo apt-get install cuda-toolkit-10-0

Thank you for your response. With nvidia-410 driver installed, I tried cuda-toolkit-10-1 and indeed, it installs successfully without a driver. However, the updated driver is still needed at runtime. For instance, deviceQuery says

CUDA driver version is insufficient for CUDA runtime version

I was responding to your question 3:

“3. Is it possible to install CUDA 10.0 or later without updating to nvidia-418?”

You can install cuda-toolkit-10-0 as I indicated. It will work with the 410 driver.

I didn’t say CUDA 10.1 would work that way.

You can install cuda-toolkit-10-1 but it will require the 418 driver.

Thank you again. I tried cuda-toolkit-10-0 too, same result.

CUDA 10.0 will work with a R410 (410.xx) driver. Either your driver install is broken, or you are not using CUDA 10.0 when you run the test that produces the “driver version is insufficent…” error message.

Well, maybe something went wrong by installing and uninstalling too many things too many times. For instance, nvidia-smi was saying “CUDA version: N/A”. I will try gain.