Installing Cuda toolkit 10.0 on Ubuntu 18 results in black boot screen

Hi all,

I am trying to install Cuda toolkit 10.0 and Nvidia drivers on ubuntu 18.04.3 using various posts and guides I found online; I need Cuda toolkit 10.0 because Tensorflow 1.13/1.14 only supports this version. For reference, these are the guides I am following


  • GPU: GeForce RTX 2070 super
  • OS: Ubuntu 18.04.3 64 bit (I have also tried on 18.04, 17.04, 16.04.6 with the respective driver and Cuda toolkit versions)

Installing Cuda toolkit, either before or after installing the Nvidia drivers, results in a black boot screen when reboot with

/dev/nvme0n1p2: clean, 185049/30498816 files, 5606916/121965056 blocks

shown at the top; I cannot even use CTRL+ALT+F2 here as the computer does not let me type on this screen. I have tried different ordering of installation because installing the Nvidia drivers first automatically installs Cuda version 10.1 or 10.2 (depending on if I use driver 430, 435 or 440).

Here are my steps

  1. Format my internal hard drive and install a clean version of ubuntu 18.04.3. Choose the "minimal installation" options so Ubuntu does not install any drivers or new software
  2. Run the below to install gcc
  3. $ sudo apt update
    $ sudo apt upgrade
    $ sudo apt install build-essential
    $ sudo apt-get install manpages-dev
  4. To check what version of the Nvidia driver to install, I check either here or run the below
  5. $ ubuntu-drivers devices

    I get a list of 430, 435 and 440. I have tried to install all 3 via ppa

  6. Run the below
  7. $ sudo add-apt-repository ppa:graphics-drivers/ppa
    $ sudo apt install nvidia-driver-430

    Yes to all prompts

  8. Reboot - the installation has worked fine and I can run $ nvidia-smi to see that driver 430 is installed, and Cuda version 10.1 has been automatically installed
  9. Download Cuda toolkit 10.0 from here And the run the below
  10. $ sudo dpkg -i cuda-repo-ubuntu1804-10-0-local-10.0.130-410.48_1.0-1_amd64.deb
    $ sudo apt-key add /var/cuda-repo-10.0/
    $ sudo apt-get update
    $ sudo apt-get install cuda
    $ export PATH=/usr/local/cuda-10.0/bin${PATH:+:${PATH}}
    $ export LD_LIBRARY_PATH=/usr/local/cuda-10.0/lib64${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}

    Yes to all prompts

  11. Reboot. Here is the issue - now I get a black boot screen as described above. This only happens when I install CUDA 10.0. If I haven't installed Cuda, and only installed the Nvidaia drivers, I can reboot the computer multiple times as the install has worked.

What can I do to fix this problem and install Cuda 10.0? I have tried installing with different Ubuntu versions and different cuda versions, different installation ordering, but I always get similar problems.

Any help would be much appreciated, as this problem has been ongoing for weeks now. Thanks

Do everything up through step 5 including step 5. Make sure you can reboot without any issues.

At step 6, modify line 4 from this:

sudo apt-get install cuda

to this:

sudo apt-get install cuda-toolkit-10-0

Other than that, complete step 6 just as you have it.

1 Like

Thank you so much Robert. That solved the problem.

Now when I run $ nvidia-smi I still see Cuda version 10.1 in the upper right corner, but I guess that is to be expected from your answer here

I still find that strange

Much appreciated. The support from Nvidia is excellent

Please change these to cuda archives also.
Thank You!