Issues with Cuda 10.0 install on Ubuntu 18.04 LTS

Current behavior after install:
Startup machine and enter password to unlock the encrypted drive.
User login screen displays but the keyboard and mouse are now disabled so you can’t login. Tried plugging in keyboard and mouse to different ports but they all had the same issue. Tried plugging monitor into other nvidia card but then monitor has no signal.
I am able to SSH into the machine, here’s some diagnostic info:

$ cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module 410.79 Thu Nov 15 10:41:04 CST 2018
GCC version: gcc version 7.3.0 (Ubuntu 7.3.0-27ubuntu1~18.04)

Steps to Reproduce (I have reproduced now by performing multiple fresh OS installs):
Install Ubuntu 18.04.2 LTS (downloaded today).
$ uname -r
4.18.0-15-generic

Follow the instructions here exactly (went with deb network install): https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html
(Note - the checksum link the in documentation is wrong, it links to cuda 9.2, needs to be updated since the docs are for cuda 10.0)

Reboot after install and observe keyboard/mouse locking behavior described above.

The install guide mentions that the most recent supported version is Ubuntu 18.04.1 with kernel version 4.15.0.

This doesn’t help much because the default is 18.04.2 and kernel 4.18 now. I looked around but I’m not sure how I can access the older versions.

I just tried installing cuda-drivers instead of the full cuda package. But I ran into the same behavior.

18.04.1 is available here:

http://old-releases.ubuntu.com/releases/bionic/

thanks!

Do you know, if I install 18.04.1 and then agree to the updates in the Ubuntu software-updater GUI, will this bump up my kernel version beyond the supported 4.15.0?

I’m assuming it might, it which case it would probably break things. Is there documentation anywhere that describes update best practices? In other words, is there a best way to go about managing OS updates to avoid breaking nvidia compatibility?

Also, do you know what the release velocity is for CUDA? I ran into a similar issue last year, where CUDA was incompatible with the official Ubuntu 16.04 LTS kernel version, but it was quickly resolved within a few days with a new nvidia kernel module. Do you think we’ll have a fix for Ubuntu 18.04.2 soon? Or is that something that typically takes longer than a few days.

Sorry for all the questions and many thanks.

probably

Use DKMS. I’m not aware of documentation per se.

You can gauge the historical release velocity easily enough by reviewing the legacy releases page.

I’m not able to make forward looking statements here.

To be clear, I’m not confirming there is any issue with 18.04.2. I haven’t studied your case or attempted to try it myself. I’m simply pointing out that 18.04.1 is available if you wish to try it. It may be that you experience the same issue with 18.04.1

I looked at this legacy releases page https://developer.nvidia.com/cuda-toolkit-archive, but it only covers the CUDA Toolkit versions. When I faced my issue last year, the solution was distributed as the same toolkit version but it just contained an updated display driver version.

For example, even now, the display driver that comes with CUDA 10.0 (410.79) is lower than the recommended driver (410.93) that nvidia tells me to download if I go through the drivers page: https://www.geforce.com/drivers/results/141700

[/quote]

Gotcha, no worries. I downloaded 18.04.1 and going to give it a try, thanks again for sending the link. I used Software Updater to install all the available updates and the kernel version remained at 4.15.0 so will see if things work now with CUDA 10.0

This is as it should be and should not be surprising. A CUDA release is typically bundled with the minimal driver version necessary to support it. The bundle is not changed as newer drivers become available. Rather, after installing a CUDA release, you can update the driver to any later version whenever you, as the user, deem it appropriate to do so. In my experience, it is rarely necessary.

Ok cool thanks njuffa. Maybe it was an exception but the only other time I’ve dealt with installing cuda, the existing cuda 9.1 download was updated with a newer driver version, and so that’s where I was coming from. https://devtalk.nvidia.com/default/topic/1028802/cuda-setup-and-installation/problems-with-cuda-9-1-in-ubuntu-16-04/post/5233969/#5233969

Anyways, I tried the install with Ubuntu 16.04.1 and things are working! Got the nbody example running. So it seems something is incompatible with the current Ubuntu release (16.04.2).

Is there a way to file a bug report? Not sure if the forums are separate or if these issues are submitted to the development team.

You can observe driver release velocity historically at http://www.nvidia.com/drivers
It may be fairly tedious. Drivers are released pretty often, at least compared to CUDA toolkit versions. I don’t see how release velocity matters unless you have an idea of whether a fix is coming for something, or not.

You can file a bug report.

Instructions are linked in a sticky post at the top of the cuda programming forum:

https://devtalk.nvidia.com/default/topic/1044668/cuda-programming-and-performance/-how-to-report-a-bug/

awesome thanks

Linking the bug id here for reference: https://developer.nvidia.com/nvidia_bug/2512935

I did the exact same thing and got the same problem.

I will try to switch back to 18.04.1.

I meet the same problem , so any solution?

Hi, has anyone been able to solve this?

I have a similar situation, I switched to Ubuntu 18.04.1 and make sure the prerequisites met the table on the installation guide, but still have some issues. I don’t get any errors when running sudo apt-get install cuda but after rebooting I have a black screen with the mouse cursor but I’m not able to use the mouse nor the keyboard.

I will really appreciate some help, I’ve been trying for a couple of days with no luck.

I’m using a GeForce GTX 1060, Ubuntu 18.04.1, Kernel 4.15.0 and CUDA 10.1.

It has nothing to do with the NVIDIA driver. My box runs Ubuntu 18.04.2 and has a geforce 1070. Tried different nvidia drivers and the problem didn’t go away. It turned out an Ubuntu package is missing. Installing “sudo apt install xserver-xorg-input-all” solved the problem.

Installing the package xserver-xorg-input-all worked for me as well.