Cuda 11.2 installation on jetpack 4.6.2

I update the cuda 11.2 with the link below (CUDA Toolkit 11.2 Downloads | NVIDIA Developer.

I could not successfully install: the error message is : Unpacking nvidia-kernel-common-460 (460.27.04-0ubuntu1) …
Selecting previously unselected package nvidia-dkms-460.
Preparing to unpack …/21-nvidia-dkms-460_460.27.04-0ubuntu1_arm64.deb …
Unpacking nvidia-dkms-460 (460.27.04-0ubuntu1) …
Selecting previously unselected package libnvidia-extra-460:arm64.
Preparing to unpack …/22-libnvidia-extra-460_460.27.04-0ubuntu1_arm64.deb …
Unpacking libnvidia-extra-460:arm64 (460.27.04-0ubuntu1) …
Selecting previously unselected package nvidia-driver-460.
Preparing to unpack …/23-nvidia-driver-460_460.27.04-0ubuntu1_arm64.deb …
Unpacking nvidia-driver-460 (460.27.04-0ubuntu1) …
Selecting previously unselected package nvidia-utils-460.
Preparing to unpack …/24-nvidia-utils-460_460.27.04-0ubuntu1_arm64.deb …
Unpacking nvidia-utils-460 (460.27.04-0ubuntu1) …
dpkg: error processing archive /tmp/apt-dpkg-install-UbdHOO/24-nvidia-utils-460_460.27.04-0ubuntu1_arm64.deb (–unpack):
trying to overwrite ‘/usr/bin/nvidia-xconfig’, which is also in package nvidia-l4t-x11 32.7.1-20220219090344
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Selecting previously unselected package libnvidia-cfg1-460:arm64.
Preparing to unpack …/25-libnvidia-cfg1-460_460.27.04-0ubuntu1_arm64.deb …
Unpacking libnvidia-cfg1-460:arm64 (460.27.04-0ubuntu1) …
Selecting previously unselected package xserver-xorg-video-nvidia-460.
Preparing to unpack …/26-xserver-xorg-video-nvidia-460_460.27.04-0ubuntu1_arm64.deb …
Unpacking xserver-xorg-video-nvidia-460 (460.27.04-0ubuntu1) …
Selecting previously unselected package nvidia-modprobe.
Preparing to unpack …/27-nvidia-modprobe_460.27.04-0ubuntu1_arm64.deb …
Unpacking nvidia-modprobe (460.27.04-0ubuntu1) …
Selecting previously unselected package screen-resolution-extra.
Preparing to unpack …/28-screen-resolution-extra_0.17.3_all.deb …
Unpacking screen-resolution-extra (0.17.3) …
Selecting previously unselected package libxnvctrl0:arm64.
Preparing to unpack …/29-libxnvctrl0_460.27.04-0ubuntu1_arm64.deb …
Unpacking libxnvctrl0:arm64 (460.27.04-0ubuntu1) …
Selecting previously unselected package nvidia-settings.
Preparing to unpack …/30-nvidia-settings_460.27.04-0ubuntu1_arm64.deb …
Unpacking nvidia-settings (460.27.04-0ubuntu1) …
Selecting previously unselected package cuda-drivers-460.
Preparing to unpack …/31-cuda-drivers-460_460.27.04-1_arm64.deb …
Unpacking cuda-drivers-460 (460.27.04-1) …
Selecting previously unselected package cuda-drivers.
Preparing to unpack …/32-cuda-drivers_460.27.04-1_arm64.deb …
Unpacking cuda-drivers (460.27.04-1) …
Selecting previously unselected package cuda-runtime-11-2.
Preparing to unpack …/33-cuda-runtime-11-2_11.2.0-1_arm64.deb …
Unpacking cuda-runtime-11-2 (11.2.0-1) …
Selecting previously unselected package cuda-cuobjdump-11-2.
Preparing to unpack …/34-cuda-cuobjdump-11-2_11.2.67-1_arm64.deb …
Unpacking cuda-cuobjdump-11-2 (11.2.67-1) …
Selecting previously unselected package cuda-cuxxfilt-11-2.
Preparing to unpack …/35-cuda-cuxxfilt-11-2_11.2.67-1_arm64.deb …
Unpacking cuda-cuxxfilt-11-2 (11.2.67-1) …
Selecting previously unselected package cuda-driver-dev-11-2.
Preparing to unpack …/36-cuda-driver-dev-11-2_11.2.72-1_arm64.deb …
Unpacking cuda-driver-dev-11-2 (11.2.72-1) …
Selecting previously unselected package cuda-cudart-dev-11-2.
Preparing to unpack …/37-cuda-cudart-dev-11-2_11.2.72-1_arm64.deb …
Unpacking cuda-cudart-dev-11-2 (11.2.72-1) …
Selecting previously unselected package cuda-nvcc-11-2.
Preparing to unpack …/38-cuda-nvcc-11-2_11.2.67-1_arm64.deb …
Unpacking cuda-nvcc-11-2 (11.2.67-1) …
Selecting previously unselected package cuda-nvprune-11-2.
Preparing to unpack …/39-cuda-nvprune-11-2_11.2.67-1_arm64.deb …
Unpacking cuda-nvprune-11-2 (11.2.67-1) …
Selecting previously unselected package cuda-compiler-11-2.
Preparing to unpack …/40-cuda-compiler-11-2_11.2.0-1_arm64.deb …
Unpacking cuda-compiler-11-2 (11.2.0-1) …
Selecting previously unselected package cuda-nvrtc-dev-11-2.
Preparing to unpack …/41-cuda-nvrtc-dev-11-2_11.2.67-1_arm64.deb …
Unpacking cuda-nvrtc-dev-11-2 (11.2.67-1) …
Selecting previously unselected package libcublas-dev-11-2.
Preparing to unpack …/42-libcublas-dev-11-2_11.3.1.68-1_arm64.deb …
Unpacking libcublas-dev-11-2 (11.3.1.68-1) …
Selecting previously unselected package libcufft-dev-11-2.
Preparing to unpack …/43-libcufft-dev-11-2_10.4.0.72-1_arm64.deb …
Unpacking libcufft-dev-11-2 (10.4.0.72-1) …
Selecting previously unselected package libcurand-dev-11-2.
Preparing to unpack …/44-libcurand-dev-11-2_10.2.3.68-1_arm64.deb …
Unpacking libcurand-dev-11-2 (10.2.3.68-1) …
Selecting previously unselected package libcusolver-dev-11-2.
Preparing to unpack …/45-libcusolver-dev-11-2_11.0.2.68-1_arm64.deb …
Unpacking libcusolver-dev-11-2 (11.0.2.68-1) …
Selecting previously unselected package libcusparse-dev-11-2.
Preparing to unpack …/46-libcusparse-dev-11-2_11.3.1.68-1_arm64.deb …
Unpacking libcusparse-dev-11-2 (11.3.1.68-1) …
Selecting previously unselected package libnpp-dev-11-2.
Preparing to unpack …/47-libnpp-dev-11-2_11.2.1.68-1_arm64.deb …
Unpacking libnpp-dev-11-2 (11.2.1.68-1) …
Selecting previously unselected package libnvjpeg-dev-11-2.
Preparing to unpack …/48-libnvjpeg-dev-11-2_11.3.1.68-1_arm64.deb …
Unpacking libnvjpeg-dev-11-2 (11.3.1.68-1) …
Selecting previously unselected package cuda-libraries-dev-11-2.
Preparing to unpack …/49-cuda-libraries-dev-11-2_11.2.0-1_arm64.deb …
Unpacking cuda-libraries-dev-11-2 (11.2.0-1) …
Selecting previously unselected package cuda-cupti-11-2.
Preparing to unpack …/50-cuda-cupti-11-2_11.2.67-1_arm64.deb …
Unpacking cuda-cupti-11-2 (11.2.67-1) …
Selecting previously unselected package cuda-cupti-dev-11-2.
Preparing to unpack …/51-cuda-cupti-dev-11-2_11.2.67-1_arm64.deb …
Unpacking cuda-cupti-dev-11-2 (11.2.67-1) …
Selecting previously unselected package cuda-nvdisasm-11-2.
Preparing to unpack …/52-cuda-nvdisasm-11-2_11.2.67-1_arm64.deb …
Unpacking cuda-nvdisasm-11-2 (11.2.67-1) …
Selecting previously unselected package cuda-gdb-11-2.
Preparing to unpack …/53-cuda-gdb-11-2_11.2.67-1_arm64.deb …
Unpacking cuda-gdb-11-2 (11.2.67-1) …
Selecting previously unselected package cuda-nvprof-11-2.
Preparing to unpack …/54-cuda-nvprof-11-2_11.2.67-1_arm64.deb …
Unpacking cuda-nvprof-11-2 (11.2.67-1) …
Selecting previously unselected package cuda-nvtx-11-2.
Preparing to unpack …/55-cuda-nvtx-11-2_11.2.67-1_arm64.deb …
Unpacking cuda-nvtx-11-2 (11.2.67-1) …
Selecting previously unselected package cuda-sanitizer-11-2.
Preparing to unpack …/56-cuda-sanitizer-11-2_11.2.67-1_arm64.deb …
Unpacking cuda-sanitizer-11-2 (11.2.67-1) …
Selecting previously unselected package cuda-command-line-tools-11-2.
Preparing to unpack …/57-cuda-command-line-tools-11-2_11.2.0-1_arm64.deb …
Unpacking cuda-command-line-tools-11-2 (11.2.0-1) …
Selecting previously unselected package nsight-compute-2020.3.0.
Preparing to unpack …/58-nsight-compute-2020.3.0_2020.3.0.18-1_arm64.deb …
Unpacking nsight-compute-2020.3.0 (2020.3.0.18-1) …
Selecting previously unselected package cuda-nsight-compute-11-2.
Preparing to unpack …/59-cuda-nsight-compute-11-2_11.2.0-1_arm64.deb …
Unpacking cuda-nsight-compute-11-2 (11.2.0-1) …
Selecting previously unselected package nsight-systems-cli-2020.4.3.
Preparing to unpack …/60-nsight-systems-cli-2020.4.3_2020.4.3.7-1_arm64.deb …
Unpacking nsight-systems-cli-2020.4.3 (2020.4.3.7-10543b6) …
Selecting previously unselected package cuda-nsight-systems-11-2.
Preparing to unpack …/61-cuda-nsight-systems-11-2_11.2.0-1_arm64.deb …
Unpacking cuda-nsight-systems-11-2 (11.2.0-1) …
Selecting previously unselected package cuda-nvml-dev-11-2.
Preparing to unpack …/62-cuda-nvml-dev-11-2_11.2.67-1_arm64.deb …
Unpacking cuda-nvml-dev-11-2 (11.2.67-1) …
Selecting previously unselected package cuda-visual-tools-11-2.
Preparing to unpack …/63-cuda-visual-tools-11-2_11.2.0-1_arm64.deb …
Unpacking cuda-visual-tools-11-2 (11.2.0-1) …
Selecting previously unselected package cuda-tools-11-2.
Preparing to unpack …/64-cuda-tools-11-2_11.2.0-1_arm64.deb …
Unpacking cuda-tools-11-2 (11.2.0-1) …
Selecting previously unselected package cuda-samples-11-2.
Preparing to unpack …/65-cuda-samples-11-2_11.2.67-1_arm64.deb …
Unpacking cuda-samples-11-2 (11.2.67-1) …
Selecting previously unselected package cuda-documentation-11-2.
Preparing to unpack …/66-cuda-documentation-11-2_11.2.67-1_arm64.deb …
Unpacking cuda-documentation-11-2 (11.2.67-1) …
Selecting previously unselected package cuda-toolkit-11-2.
Preparing to unpack …/67-cuda-toolkit-11-2_11.2.0-1_arm64.deb …
Unpacking cuda-toolkit-11-2 (11.2.0-1) …
Selecting previously unselected package cuda-11-2.
Preparing to unpack …/68-cuda-11-2_11.2.0-1_arm64.deb …
Unpacking cuda-11-2 (11.2.0-1) …
Selecting previously unselected package cuda.
Preparing to unpack …/69-cuda_11.2.0-1_arm64.deb …
Unpacking cuda (11.2.0-1) …
Selecting previously unselected package linux-headers-4.15.0-184.
Preparing to unpack …/70-linux-headers-4.15.0-184_4.15.0-184.194_all.deb …
Unpacking linux-headers-4.15.0-184 (4.15.0-184.194) …
Selecting previously unselected package linux-headers-4.15.0-184-generic.
Preparing to unpack …/71-linux-headers-4.15.0-184-generic_4.15.0-184.194_arm64.deb …
Unpacking linux-headers-4.15.0-184-generic (4.15.0-184.194) …
Selecting previously unselected package linux-headers-generic.
Preparing to unpack …/72-linux-headers-generic_4.15.0.184.172_arm64.deb …
Unpacking linux-headers-generic (4.15.0.184.172) …
Selecting previously unselected package nvidia-prime.
Preparing to unpack …/73-nvidia-prime_0.8.16~0.18.04.1_all.deb …
Unpacking nvidia-prime (0.8.16~0.18.04.1) …
Errors were encountered while processing:
/tmp/apt-dpkg-install-UbdHOO/11-libnvidia-compute-460_460.27.04-0ubuntu1_arm64.deb
/tmp/apt-dpkg-install-UbdHOO/15-libnvidia-gl-460_460.27.04-0ubuntu1_arm64.deb
/tmp/apt-dpkg-install-UbdHOO/24-nvidia-utils-460_460.27.04-0ubuntu1_arm64.deb

Hi @lwzhang6, those packages aren’t for Jetson, they are for ARM server (SBSA). The GPU drivers and CUDA for Jetson only comes with JetPack. This is because Jetson uses an integrated GPU, whereas other architectures use discrete GPU(s) connected over PCIe or NVLINK.

Now I have Jetpack 4.5.1. Cuda 10.2 I wanted to upgrade my cudnn from 8.0 to 8.1, can you direct me how to make the update? can I use *amd.deb? it says mismatch. I am using nvidia jetson xAVIER NX, which cudnn i should use? please note it has amd64. thank you!
cuDNN Runtime Library for Ubuntu18.04 (Deb)

cuDNN Developer Library for Ubuntu18.04 (Deb)

It isn’t supported to independently update the CUDA/cuDNN/TensorRT versions outside of JetPack. So to update you would need to upgrade the entire JetPack version of your device.

thank you. If I wanted cuda11.2, cudnn8.1, tensorRT7.2. Which version of jetpack I should install?

sorry, since cuda version only goes with 10.2. I would ask: If I wanted cuda10.2, cudnn8.1, tensorRT7.2. Which version of jetpack I should install?

It looks like the closest would be JetPack 4.5, which come with CUDA 10.2, cuDNN 8.0, and TensorRT 7.1. Or you could use JetPack 4.6 with CUDA 10.2, cuDNN 8.2, and TensorRT 8.0. You can check the versions by clicking on each JetPack link on this page: https://developer.nvidia.com/embedded/jetpack-archive

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.