Cuda 2.0 does not work on OpenSuse 10.2

Hi All,

I’ve been trying to get my cuda enabled card to work using the svn version 716 of Nvidia Texture Tools. I can get it working when I build the 2.0.4 version with Cuda 1.1 installed but not Cuda 2.0. I install NVIDIA_CUDA_Toolkit_2.0_suse10.2_x86_64.run but I tried a few of the other vendor Cuda toolkits too. Everything builds. There are no warnings while I build svn716. But Cuda does not work.

I have an 8600 gts card using driver NVIDIA-Linux-x86_64-177.80-pkg2.run. I also tried NVIDIA-Linux-x86_64-177.73-pkg2.run and NVIDIA-Linux-x86_64-169.09-pkg2.run. Cuda 2.0 does not work on any of these. The test I do to verify if Cuda works is

The Segmentation faults are a known defect of the svn version 716 of Nvidia Texture Tools. The important thing here is the times are almost identical. When Cuda works with Cuda 1.1 installed, I get about .3 second processing time for the command “nvcompress -bc2 -nomips tx_0_0.png”.

cartrite

Its not clear how you determined that CUDA_2.0 isn’t working. What seems more likely is that the texture tools aren’t working.

Have you tried running the SDK apps?

I just installed and built the SDK today. I am able to run all the apps that I tried but I’m not sure how to test if Cuda is working or not. Running nvcompress will produce output like this when Cuda is active and enabled.

I am helping someone who is developing tools that process large files. I do a run on a file that is 65536x32768 and the programs tile that large file and convert raw binary to dxt3 or dxt5. This is about 2048 tiles. At 2 seconds per tile vs. .4 seconds per tile the time adds up when Cuda is not enabled.

This version of nvcompress is from NVIDIA_CUDA_Toolkit_1.1_Suse10.2_x86.run and nvidia-texture-tools-2.0.4.tar.gz.

As to your question. It may very well be a problem with the tools I’m building. That is what I’m trying to find out. Since both the tools and Cuda are connected with Nvidia, I thought someone here might know something about this.

cartrite

If the SDK apps work fine (and aren’t claiming ‘emulation’ or something similar in their output), then CUDA is working fine on your system.

If you’re using nvcompress from/with a NVIDIA_CUDA_Toolkit_1.1_Suse10.2_x86.run package while trying to use CUDA_2.0 bits elswhere, then I’d expect problems. You should follow-up via the texture tools support mechanism to get this addressed.

That is not what I’m try to do. I’m trying to use with NVIDIA_CUDA_Toolkit_2.0_suse10.2_x86_64.run with nvidia-texture-tools svn version716.

Cuda doesn’t work when I use them together. It does work when I use NVIDIA_CUDA_Toolkit_1.1_Suse10.2_x86.run and nvidia-texture-tools-2.0.4.tar.gz.

I already did post something at the other forum called Nvidia developers forum. I was just hoping someone over here may have heard something about this.

I haven’t heard anything over there.

I was suspecting that something is wrong with the nvidia texture tools. This seems to be confirming that suspicion. I’ll start using the SDK tools and see whats up.

I did try cucaprof. That will not work right with Cuda 2.0 installed either. At least when I try to run nvcompress. It doesn’t save the temporary output file so the session is blank. It reports error 97. The file is there while nvcompress is running but as soon as it is finished, the file is gone.

cartrite

I had a look at the nbody program and that looks like Cuda 2.0 is working with that program. The terminal reports “Using device 0: GeForce 8600 GTS” and the simulation seems to work normally.

Is that normal output for a Cuda enabled 8600 GTS?

cartrite

Yes, that nbody output proves that CUDA is working.

I’m afraid that all the other issues you’re having are not explicitly CUDA problems, they’re problems with those tools/packages (textures, cucaprof, etc).

Thanks for your help. I’m pretty sure that the problem is with the tools now.
cartrite

Apparently, a pair of quotes ("") were wrapping around the cuda library name on line 78 in “CudaUtils.cpp” Library nvcuda(NV_LIBRARY_NAME(“cuda”));" was changed to “Library nvcuda(NV_LIBRARY_NAME(cuda));”. Ignacio committed a fix for this in svn nvidia-texture-tools.

Thanks to all for your help and time here.

cartrite