CUDA 5 not working on OSX 10.6.8 Snow Leopard?

Hi,
when I upgraded to CUDA 5.0 it seemed to install alright but when I tried the deviceQuery examples I got

cudaGetDeviceCount returned 35
-> CUDA driver version is insufficient for CUDA runtime version

I have

nvcc -V
nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2012 NVIDIA Corporation
Built on Fri_Sep_28_16:10:16_PDT_2012
Cuda compilation tools, release 5.0, V0.2.1221

kexstat | grep -i cuda
135 0 0x8105d000 0x2000 0x1000 com.nvidia.CUDA (1.1.0) <4 1>

when checking the CUDA driver in the preferences it shows as
Driver Version: 5.045
GPU Driver Version: 1.6.36.10 (256.00.35f11)

I also tried to install the newest drivers for MAC with no change.
Compiling for i386 or x86_64 architecture made no difference.
I tried the Driver version of Device Query and get

./deviceQueryDrv Starting…

CUDA Device Query (Driver API) statically linked version
cuInit(0) returned 3
-> CUDA_ERROR_NOT_INITIALIZED

Does anyone know anything about this? Does the latest CUDA 5 release simply not work on Snow Leopard 10.8.6? I know it’s not supported officially, but it seemed some people had success?

This is on a 2010 macbook pro with NVIDIA GeForce 320M

Any help appreciated!
Thomas.

CUDA Toolkit 5.0 requires Mac OS X 10.7 or newer.

Hi eugeneo, thanks for this - no way around upgrading then? I saw some comments of people saying even though not supported below 10.7, CUDA 5 still worked for them. But maybe that was rubbish?

Thomas.