Cuda 6: Only the versions 2008, 2010, and 2012 are supported

Hi,

I get “Only the versions 2008, 2010, and 2012 are supported” when I try to run nvcc.
I have vs2012 and vs2013 installed. What is the problem ?

Ok, the issue was that visual studio 2013 was overriding Visual studio 2012 environment setup. Is there any planned support for visual studio 2013 or we have to revert to nvcc.profile editing again?

Thanks.

A long time ago, only VS2008 was officially supported. Then, later, VS2010 was added. In CUDA 6.0, VS2012 was added. It seems reasonable to assume that a future CUDA release may support VS2013.

Excuse me for my whining. Technically you are right, support for vs2010 was added long after everyone switched to vs2012. Vs2012 support was added but everyone I know now is using vs2013. It seems reasonable to assume that vs2013 support will be added by the time no one is using it anymore.

It’s not like it’s too hard to make nvcc stop complaining and use whatever compiler you want it to use.

Thanks.