Cuda 9.1 code update issue with VS2015

Hello Nvidia Team,
I tried to upgrade cuda 4.2 project with cuda 9.1 VS 2015, i updated CUSP file in toolkit folder.
while compiling the project i am getting some errors–

Severity Code Description Project File Line Suppression State
Error invalid redeclaration of type name “thrust::system::cpp::detail::tag” ClothsimLib C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.1\include\thrust\system\cpp\detail\tag.h 31
Error “tag” has already been declared in the current scope ClothsimLib C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.1\include\thrust\system\cuda\detail\tag.h 72
Error MSB3721 The command ““C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.1\bin\nvcc.exe” -gencode=arch=compute_30,code=“sm_30,compute_30” -gencode=arch=compute_35,code=“sm_35,compute_35” -gencode=arch=compute_37,code=“sm_37,compute_37” -gencode=arch=compute_50,code=“sm_50,compute_50” -gencode=arch=compute_52,code=“sm_52,compute_52” -gencode=arch=compute_60,code=“sm_60,compute_60” -gencode=arch=compute_61,code=“sm_61,compute_61” -gencode=arch=compute_70,code=“sm_70,compute_70” --use-local-env --cl-version 2015 -ccbin “C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin\x86_amd64” -x cu -I"C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.1\include” -I"C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.1\include" -I"C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.1\include" -G --keep-dir x64\Debug -maxrregcount=0 --machine 64 --compile -cudart static -g -DWIN32 -DNDEBUG -D_LIB -D_MBCS -Xcompiler “/EHsc /W3 /nologo /Od /FS /Zi /RTC1 /MDd " -o x64\Debug\core_func.cu.obj “C:\Users\ivasa\Desktop\2015\Clothsim\solvers\gpu_solver\core_func.cu”” exited with code 1. ClothsimLib C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\BuildCustomizations\CUDA 9.1.targets 707

Please help me to resolve this issue.

The project may need to be re-written to use the newer thrust and/or cusp versions.

Thanks txbob.

Hello txbox,
as you suggested me to update the newer cusp and thrust for the above errors to compile the code.
Now i successfully compiled and upgraded with 9.1 toolkit.
while i am using the exe to load obj file, i am getting an error with cmd window and project gone exit,
please check the error and help me to solve the problem–

Status: Using GLEW 2.1.0
CUDA error 9 [C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.1\include\thrust/system/cuda/detail/parallel_for.h, 143]: invalid configuration argument
Thurst Runtime Error: parallel_for failed: invalid configuration argument
Press any key to continue . . .

Please guide me to solve the above issue.

thanks

Hello txbox,

Please help me which driver needed for Quadro P4000 with cuda 8 toolkit.

Thanks

go to

http://www.nvidia.com/drivers

and use the wizard

Thanks txbob,

I am using the driver 390.65 and getting the run time error and project gone exit.

Status: Using GLEW 2.1.0
CUDA error 9 [C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.1\include\thrust/system/cuda/detail/parallel_for.h, 143]: invalid configuration argument
Thurst Runtime Error: parallel_for failed: invalid configuration argument
Press any key to continue . . .

Please clear about “and use the wizard”.

Please help me with above run time error.

thanks

Hello txbob,

using the cuda-memcheck i am getting this, please check

[b]Microsoft Windows [Version 10.0.16299.309]
© 2017 Microsoft Corporation. All rights reserved.

C:\Windows\system32>cuda-memcheck C:\Users\ivasa\Desktop\2015\bin\Clothsim.exe
========= CUDA-MEMCHECK
---- General Information for device 0----
Name: Quadro M1200
Compute capability: 5.0
Clock rate: 1148000
Device copy overlap: Enabled
Kernel execition timeout : Enabled

---- Memory Information for device 0----
Total global mem: 4294967296
Total constant mem: 65536
Max mem pitch: 2147483647
Texture Alignment: 512

---- MP Information for device 0----
Multiprocessor count: 5
Shared mem per mp: 49152
Registers per mp: 65536
Threads in warp: 32
Max threads per block: 1024
Max thread dimensions: (1024 1024 64)
Max grid dimensions: (2147483647 65535 65535)

Status: Using GLEW 2.1.0
CUDA error 33 [C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.1\include\thrust/system/cuda/detail/parallel_for.h, 143]: invalid resource handle
Thurst Runtime Error: parallel_for failed: invalid resource handle
========= Internal Memcheck Error: Memcheck failed initialization as some other tools is currently attached. Please make sure that nvprof and Nsight Visual Studio Edition are not being run simultaneously
========= Saved host backtrace up to driver entry point at error
========= Host Frame:C:\Windows\system32\nvcuda.dll (cuGraphicsResourceGetMappedPointer + 0x1a9d38) [0x1b7407]
========= Host Frame:C:\Users\ivasa\Desktop\2015\bin\cudart64_91.dll (_cudaInitManagedRuntime + 0x3485) [0x10945]
========= Host Frame:C:\Users\ivasa\Desktop\2015\bin\cudart64_91.dll (_cudaInitManagedRuntime + 0x51b1) [0x12671]
========= Host Frame:C:\Users\ivasa\Desktop\2015\bin\cudart64_91.dll (cudaD3D11SetDirect3DDevice + 0x4c6) [0x332e6]
========= Host Frame:C:\Users\ivasa\Desktop\2015\bin\cudart64_91.dll (_cudaInitManagedRuntime + 0x51eb) [0x126ab]
========= Host Frame:C:\Users\ivasa\Desktop\2015\bin\cudart64_91.dll (_cudaInitManagedRuntime + 0x53b7) [0x12877]
========= Host Frame:C:\Users\ivasa\Desktop\2015\bin\cudart64_91.dll (cudaSetDevice + 0x35) [0x1dac5]
========= Host Frame:C:\Users\ivasa\Desktop\2015\bin\Clothsim.exe (main + 0x47) [0x7ef57]
========= Host Frame:C:\Users\ivasa\Desktop\2015\bin\Clothsim.exe (invoke_main + 0x34) [0x228394]
========= Host Frame:C:\Users\ivasa\Desktop\2015\bin\Clothsim.exe (__scrt_common_main_seh + 0x127) [0x2282c7]
========= Host Frame:C:\Users\ivasa\Desktop\2015\bin\Clothsim.exe (__scrt_common_main + 0xe) [0x22818e]
========= Host Frame:C:\Users\ivasa\Desktop\2015\bin\Clothsim.exe (mainCRTStartup + 0x9) [0x2283a9]
========= Host Frame:C:\Windows\System32\KERNEL32.DLL (BaseThreadInitThunk + 0x14) [0x11fe4]
========= Host Frame:C:\Windows\SYSTEM32\ntdll.dll (RtlUserThreadStart + 0x21) [0x6efc1]

========= ERROR SUMMARY: 1 error

C:\Windows\system32>[/b]

thanks