CUDA 9.2.88 not integrated into Visual Studio 2017 15.7.4

The installation of CUDA 9.2.88 proceeds without error, but, unlike 9.1, does not say anything about Visual Studio integration.

Opening the CUDA sample code Samples_vs2017.sln and attempting to build gives “unsupported Microsoft Visual Studio version” errors due to _MSC_VER being outside the range required by host_config.h. For VS2017 15.7.4, _MSC_VER is 1914, and host_config requires it to be in the range 1600-1913.

As suggested by previous posters, I have tried changing the test in host_config.h from

#if _MSC_VER < 1600 || _MSC_VER > 1913
#if _MSC_VER < 1600 || _MSC_VER > 1914

This allows me to compile the deviceQuery and some other samples (there are multiple copies of host_config.h, and I only modified one). Running deviceQuery gives the correct result.

QUESTION 1: Will CUDA 9.2 support VS 2017 15.7.4, or future minor updates of Visual Studio? Since Microsoft started changing the MSC_VER for every minor update, it breaks the hard-wired limit in host_config.h, while it seems unlikely that CUDA will fail to work due to the change in VS.

For an existing MFC/C++ project, I want to add my CUDA files (.cu) to the project. These worked with previous versions of CUDA and Visual Studio, but with the current versions, I cannot add the files. Project / Add existing item does not give any error, but it does not add the .cu files to the list of source files.

QUESTION 2: What else do I need to do to get CUDA properly integrated into VS2017, so I can compile, link and run a project comprised mainly of C++ code, with some CUDA device code?

CUDA 9.2.88; Visual Studio 2017 15.7.4; 64-bit Windows 7

CUDA 9.2 isn’t designed to work with anything beyond 15.6.x toolchain. CUDA 9.2 won’t officially support anything beyond that.

I installed Visual Studio 15.6. However, it gives linker errors like that:

LNK2001 unresolved external symbol cudnnCreate