Visual Studio 2017 15.7.4

It has been one month since the last CUDA release (cuda_9.2.88_win10_network) and because of Microsoft updates to Visual Studio 2017 is has been a month of no productivity.

Microsoft have just released 15.7.4 and we are still waiting for NVidia to get this working with CUDA.

Please, get us productive again!

It makes NO sense to force us to reinstall Visual Studio 2017 15.0

I have many projects that need to be worked on not just CUDA.

It’s very frustrating. They should at the very least say the exact version(s) of visual studio (or the toolset) that work with CUDA 9.2

They actually do :) Table 2 in the linked installation guide:
https://docs.nvidia.com/cuda/cuda-installation-guide-microsoft-windows/index.html

See also:


for the latest fully compatible VS2017 links (15.6.7 or earlier), direct from M$

As you see in the two item you provided that we would have to go all the way back to Visual Studio 2017 15.5.7 which break other things so this is really an unsatisfactory workaround.

Basically it means that one has to have a development machine just for CUDA projects.

That isn’t remotely clear enough. If it were, this forum wouldn’t be filled with people having issues. The known incompatibility should be stated in bold letters.

This also isn’t mentioned at all in the Quick Start guide.

I am curious: what other things would this break? 15.5.7 is hardly ancient software.

Don’t blame the messenger, just pointing out what works. ;) As an alternative, install the 15.6 toolkit from the latest Visual Studio installer, and just use that for compiling your CUDA code. /thread

njuffa If you are also working in .NET Core 2.1 (which is still very new) then the recent Visual Studio 2017 updates address issues in this environment. In this case version 15.7.0 is when .NET Core 2.1 was released!

I tried installing the CUDA toolkit with both VS2017 15.6.7 and 15.5.7 and it still failed. Any ideas what the problem could be?

You’re going to have to check the CUDA installer log files to see what failed. When unpacked, the CUDA imstaller has some xml files that indicate which packages get installed. If this is a new system, easier to just wipe the Windows installation and to reinstall fresh. Otherwise the debug route is the way to go. Probably easier to start a new thread on your specific topic as it is a different issue altogether.

Edit 1: Try this and see if it helps: (especially if that was the error you experienced)
https://devtalk.nvidia.com/default/topic/1032800/cuda-setup-and-installation/visual-studio-integration-failed-/

Edit 2: See also this thread:
https://devtalk.nvidia.com/default/topic/1035794/cuda-setup-and-installation/cuda-9-2-quot-nvidia-installer-failed-quot-/

Edit 3: Another relevant thread:
https://devtalk.nvidia.com/default/topic/1033111/cuda-setup-and-installation/cuda-9-1-cannot-install-due-to-failed-visual-studio-integration/