Nvidia Installer Failed while installing Cuda toolkit 9.2

Hello,
I’m interested in learning GPU programming. So I wanted to install CUDA toolkit 9.2( Which I believe is the latest version). After downloading the setup and when I choose the path and the graphical installer opens where I choose the type as Express Installation. After a few seconds of pressing the next button there’s a message saying that the NVIDIA installer failed and all the components are uninstalled. The visual Studio integration has also failed.

I have a Nvidia GTX GeForce 950 M for Notebook versions with a memory of 4 GB.
My laptop has 8 GB ram and a Intel i7-4720 HQ processor.
I’m currently using Windows 10, 64 bit.
I have the Microsoft Visual Studio 2017 Community Edition installed.

After many failed attempts I tried resetting my laptop and installed VS2017 and the display driver ( v.397.93) but still I get the same issues. I’ve attached the System Information from the Nvidia Control Panel.

NVIDIA System Information 05-31-2018 19-29-36.txt (3.29 KB)

CUDA 9.2 install is a no go with VS 2017 beyond the initial release (there have been 3 as of today.) Uninstall the one you have now, and install version 15.6.7 from this page:

Installing an Earlier Release of Visual Studio 2017

Untick the notifications of updates to VS 2017 as you get them - it’s a script, not a responsible adult pushing them out

I installed the version that you have said but it still didnt work. I installed only the python package in VS.
1.PNG
2.PNG

1.PNG

You needed the “Desktop development with C++” only - and I think you can’t repair that without starting over, because the installer will update itself to 15.7.3 and then you’re toast again because the Nvidia installer will not recognize that version

I did a full reset of my laptop and installed the version that you said. I made sure that its not updated to the latest one. Still I’m getting the issue. Any other solutions ?

I was about to say “no”, but you could try VS 2015 - I had that running before deciding to update to VS 2017. Remember it’s the C/C++ compiler you’d want, not Python or any other component

I have a doubt. Why do you think the problem is with the Visual studio because even the other components fail to get installed. Its because I uninstalled Visual Studio and tried to install the toolkit. One page of the installer warned that there is no visual studio found in the PC and there was a checkbox to skip visual studio integration. I checked it and still the installer failed. That’s the reason I think its not due to the Visual Studio integration thingy.

So I faced the same problem too, failed to install despite having the newest system.
Here is the screenshot.
https://drive.google.com/open?id=0B11s0Opnet0dNVl0YnBLZU9Nb1k

Hi, problem solved. Just follow this thread:
https://devtalk.nvidia.com/default/topic/1032800/visual-studio-integration-failed-/

Hello there, the question I’m asking is that in Cuda 9.2 not only the Visual Studio integration all the components fail to get installed. I sure that my Gtx 950M supports Cuda. Any reason why it keeps on failing. I even tried contacting nVIDIA but they dont seem to be giving any solution for this. I’ll follow the steps in the thread that you shared. In the mean time if I could get cuda 9.2 installed it would be awsome.

Yup, finally it worked. I had to install the standard VGA driver and then remove all nVIDIA and Visual Studio files and restarted my computer. Then installed Visual Studio 2017 followed by the Cuda toolkit 9.2 installation and it worked like a charm.

I had similar issue on Lenovo Y700 15isk, same configuration as yours instead of GPU, my is GeForce GTX 960m.
I had preinstalled VS2017. I solved “CUDA Nvidia installation failed” problem by uninstalling nvidia graphics driver (from the control panel) and then installing cuda (v 9.2) WITHOUT unchecking VS integration right after removing driver. CUDA installs suitable driver automatically and there may be a conflict if you preinstall it in advance. In my case it was driver issue, not VS integration as I thought firstly.