CUDA Driver is apparently not being loaded in the absence of X

I am trying to set up a server on which to load CUDA applications. Due to a problem involving interfaces and the Ubuntu Server kernels, I went with the option of installing Ubuntu desktop and then stripping away the desktop.

With this uninstall of epic proportions, Xorg went. Now, where I once had a working machine with a 5 second limit on my kernel executions, I have a machine with no CUDA at all.

The exact message I’m getting is:

NVIDIA: could not open the device file /dev/nvidia0 (No such file or directory). 

cudaSafeCall() Runtime API error in file <>, line 113 : no CUDA-capable device is available.

This should seem to be consistent with the theory that in the absence of Xorg, the CUDA driver is not being loaded, and my beastly card is inaccessible. However, during the CUDA driver installation, I selected the option to modify my boot scripts to load the kernel. Clearly, this either failed or is not enough. Should I attempt to copy the script from the README into rc.local, or is something more necessary?

You need to create the necessary devices for the driver /dev/nvidia? and /dev/nvidiactl. There are instructions in the readme file with the driver package that explain in detail how to do it.

The 185 series for some reason forgets to add all required symlinks on OpenSuSE 11.1. If you install the driver via zypper. Stupid users (as me) tend to believe that everything is ok: same driver version 185.18.14, same revision tag, same md5, but not the same driver as if you install it manually.

Apparently, the QA folks for CUDA act disjunctly from the QA folks for the driver or something. Sorry, too much. Apparently, OpenSuSE 11.1 is not as supported as it seems to be…


Got it. It turns out the default script uses a path to lspci that is invalid in Ubuntu. I had to switch it from /sbin/lspci to /usr/bin/lspci. Should I submit a bug report to get this fixed in the next version?