cuda-gdb has driver error initialization

hi there,

It’s my first time to run cuda-gdb.

After using nvcc -g -G to compile .cu file, I run
cuda-gdb to debug, but I have

[root@localhost debug]# cuda-gdb simpleTemplates
NVIDIA ® CUDA Debugger
3.0 release
Portions Copyright © 2008,2009,2010 NVIDIA Corporation
GNU gdb 6.6
Copyright © 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type “show copying” to see the conditions.
There is absolutely no warranty for GDB. Type “show warranty” for details.
This GDB was configured as “i686-pc-linux-gnu”…
Using host libthread_db library “/lib/”.
(cuda-gdb) b main
Breakpoint 1 at 0x8062cb1: file, line 73.
(cuda-gdb) r
Starting program: /root/NVIDIA_GPU_Computing_SDK/C/bin/linux/debug/simpleTemplates
error: The CUDA driver failed initialization.

The error message is “error: The CUDA driver failed initialization.” Anyone has similar problem?

I run cuda 3.0 on Fedora 10 32bit pc.



What is the output of the SDK’s deviceQuery program?

I also have the same problem with BinMU.
The result of my program which is a simple array operating is incorrect!
And the debugger show the same message “error: The CUDA driver failed initialization.”
I really have no idea!

Is my graphic card broken? @@