CUDA Installation procedure for Jetson Xavier NX on Ubuntu 18.04


I am using Jetson Xavier NX for Robot Operating System (ROS) development process. The ROS distribution which I am using on Ubuntu 18.04 is Melodic. I am not able to visualize pointcloud data coming from Intel Realsense D435i in RViz. I used this package to launch the files. I am gettting some warnings when I open the launch file in Jetson. So I am not getting output in RViz.

I came to know that I need to install CUDA in Jetson Xavier NX for utilizing the GPU (ROS answers). I would like to know about the CUDA installation procedure for Jetson Xavier NX on Ubuntu 18.04.

Please help me if there is any other way to increase the performance of Jetson so that I can get poitncloud data in RViz.

Hi @ashis.1ck, if you are using the Jetson Xavier NX Developer Kit with the SD card image, then it should have already come with CUDA installed. You can check this by looking for the files under /usr/local/cuda or running /usr/local/cuda/bin/nvcc --version

If you are using a production Jetson Xavier NX module that you flashed with SDK Manager, then SDK Manager should have installed CUDA after it flashed the device.

Regarding the Realsense D435i, perhaps others from the community can lend their experience with it. You might also want to check out this thread to get it working outside of ROS first:

  1. you may use rviz to visualize from any other computer in the network after publishing topics from Jetson
  2. otherwise you will have to address the libgl etc] in order to run rviz on jetson from a container
  3. you may run i435 within the container on jetson, but run rviz outside of the container
    these are three possible directions that you may like to consider

Yes. You are right. The developer kit has already come with CUDA installed.

I tried to visualize it from other computer using ssh method. I am facing the same problem there also. I connected the camera directly to my laptop and I was able to visualize the pointcloud in RViz. My laptop has Ubuntu 20.04 installed in SSD and I am using ROS Noetic in that.

I followed this link to install librealsense on Jetson I even tried to run the package from SSD on Jetson I am still getting the same error. I don’t know where I am making the mistake, whether it is with librealsense installation or not.

Why do not you use rviz at the other computer?

Why do not you use rviz outside of the container on Jetson?

What else have you tried?

Among three proposed directions at least two are working/tested
With this they will be at least two/three working from four
but it may take a tonn of time to research them in order to be able to implement a working system, as per my experience
Reference forum section: Isaac SDK - NVIDIA Developer Forums
Direction 1, design, however, suggests to publish 435 topics from jetson container connected camera, but visualize them at separate network computer, e.g. Host PC

I think, it looks they can’t find the nvcc path.

You can see the cuda is installed or not.
=> $ dpkg -l | grep cuda

If you can’t see the $ nvcc -V, you have to set the path.

And then you still has a problem.
You shuld check nvcc path in the launch file or Makefile.

for rviz2 folks seem to use like

xhost +local:docker && docker run -it --network=host --privileged --env="DISPLAY" --env="QT_X11_NO_MITSHM=1" --volume /tmp/.X11-unix:/tmp/.X11-unix:rw osrf/ros:foxy-desktop && xhost -local:docker

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.