CUDA Libraries not working through SSH

Hi,
I logged in to my Xavier NX using my windows machine using SSH. I was able to access everything. I tried running the Imagenet model which was working fine on the Jetson Xavier NX itself.

Links - https://github.com/dusty-nv/jetson-inference
https://github.com/dusty-nv/jetson-inference/blob/master/docs/building-repo-2.md

The pipeline loaded so did the camera and it was able to recognise but the image was not shown

Images -

Img3

Hi @CodeX29, those warnings are unrelated which you can ignore. You won’t see the OpenGL video feed window over SSH because that only works when a display is directly attached to your Jetson, or you are using remote desktop like VNC.

If you need to view the output video from your PC, what I recommend is streaming it from your Jetson via RTP: https://github.com/dusty-nv/jetson-inference/blob/master/docs/aux-streaming.md#transmitting-rtp

Hi,
Thanks a lot for the support and help,
Can you recommend a good Remote Desktop software that I can use to connect to my Jetson Xavier NX ?
I tried using VNC server and even though my Jetson was about a metre away from my PC, the VNC server output was lagging a lot.

My Internet looks good so I don’t think that’s an issue

You might want to check this post about Remote Desktop or create a new topic: