CUDA - MathLink incompatibilty? Mathematica CUDA MathLink CUBLAS

Hi,
I’m trying to speed up some calculations in Mathematica 7.01 by using MathLink and CUDA (CUBLAS library).
Threre’s nothing wrong with compilation of program itself, but when i`m trying to install it into Mathematica, for example
[font=“Courier New”]
SetDirectory["~myHome"] (myHome contains binary file)
link = Install[“binary.bin”] (this is the CUBLAS enabled file)
[/font]
the result is:
[font=“Courier New”]
LinkOpen::linke: Could not find MathLink executable
$Failed
[/font]
I compiled it with “mcc” prepared build script from Wolfram and also manually using “gcc” with the same result. Then I tried to install simple CUDA program(compiled by “nvcc”) for vector adding -> the same result. OpenCL version of this simple program works fine as well as “standard cpu” multithread and single thread variations of the same program. I’m running Mathematica 7.01, Ubuntu 8.10 64bit, CUDA 2.3, OpenCL 1.0, Intel i7 950, GeForce GTX295.
Can somebody help me to determine the problem?
Thanks
Martin

Is it maybe that the directory containing libcublas (and other CUDA libraries) is not in your LD_LIBRARY_PATH, so that Mathematica cannot find the dependency when loading your MathLink program?