Cuda-memcheck.exe weird behavior on Tesla C2075 (even on CUDA examples).


I’m trying to use cuda-memcheck.exe to debug one of our CUDA programs. But I get very non-sensical behavior (basically just unknown errors, with no kernel names).

I then tried using cuda-memcheck.exe on one of the CUDA SDK Examples, the “Matrix Multiplication (CUDA Runtime API Version)” (from When I run the matrixmul.exe through cuda-memcheck.exe, the multiplications fail (several thousand errors). It runs fine without matrixmul.exe.

I also notice that the display is scrambled with random pixels during the kernel launch (I’ve attached a monitor to the C2075. It is running in TCC mode.). I tried removing the monitor and running through a VNC client, but the matrixMul example still fails.

I’m running Win7 Pro 64-bit with the following driver:


| NVIDIA-SMI 3.296.70   Driver Version: 296.70         |


| Nb.  Name            TCC/WDDM | Bus Id        Disp.  | Volatile ECC SB / DB |

| Fan   Temp   Power Usage /Cap | Memory Usage         | GPU Util. Compute M. |


| 0.  Tesla C2075          TCC  | 0000:01:00.0  On     |         0          0 |

|  30%   66 C  P12   36W / 225W |   0%    9MB / 5375MB |    0%     Default    |


| Compute processes:                                               GPU Memory |

|  GPU  PID     Process name                                       Usage      |


|  No running compute processes found                                         |


Memcheck.exe is from the the CUDA 4.2.9 toolkit.

Can somebody help me here?