Cuda remove 10.1 and install 10.0 Ubuntu 18.04

I followed:

and installed cuda 10.1 – however, there is a known issue when trying to compile a popular ML algo

So, I am attempting to uninstall 10.1 and install 10.0.

I have run the following:
sudo /usr/local/cuda-10.1/bin/cuda-uninstaller
this did not work as the unistaller script was not found, so I ran the following:

sudo apt-get --purge remove cuda-10.1
Which seemed to work…

I moved on to run:
sudo dpkg -i cuda-repo-ubuntu1804-10-0-local-10.0.130-410.48_1.0-1_amd64.deb
sudo apt-key add /var/cuda-repo-10-0-local-10.0.130-410.48/
sudo apt-get update
sudo apt-get install cuda
However, this tries to reinstall 10.1.

Addtionally – 10.1 is still loaded and running – nvidia-smi reports as 10.1; nvcc -V reports similarly… Cuda compilation tools, release 9.1, V9.1.85

Any help would be greatly appreciated. I am trying to unistall cuda 10.1 and then install 10.0 so I can compile gpu enabled xgboost

What am I doing wrong?


Instead of this:

sudo apt-get install cuda

do this:

sudo apt-get install cuda-10-0

and nvidia-smi reporting the cuda version is the cuda driver version, not runtime version. it is OK if that reports cuda 10.1 if you install cuda 10.0

If you have something that is reporting:

Cuda compilation tools, release 9.1, V9.1.85

then you must also have that version installed somewhere, and you are not following these steps in the install guide, which are mandatory steps:


You might want to start by reading the entire install guide.

You might want to understand the difference between runfile install method and package manager install method.

The uninstall scripts pertain to runfile install, not package manager install. So if you run a package manager install, its no surprise that runfile uninstall scripts are not found.

1 Like

Thanks for the quick reply:
I ran:
sudo apt-get install cuda-10-0

Then checked the following:

./deviceQuery Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

Detected 1 CUDA Capable device(s)

Device 0: “GeForce RTX 2080”
CUDA Driver Version / Runtime Version 10.1 / 10.1
CUDA Capability Major/Minor version number: 7.5
Total amount of global memory: 7949 MBytes (8335327232 bytes)
(46) Multiprocessors, ( 64) CUDA Cores/MP: 2944 CUDA Cores
GPU Max Clock rate: 1800 MHz (1.80 GHz)
Memory Clock rate: 7000 Mhz
Memory Bus Width: 256-bit
L2 Cache Size: 4194304 bytes
Maximum Texture Dimension Size (x,y,z) 1D=(131072), 2D=(131072, 65536), 3D=(16384, 16384, 16384)
Maximum Layered 1D Texture Size, (num) layers 1D=(32768), 2048 layers
Maximum Layered 2D Texture Size, (num) layers 2D=(32768, 32768), 2048 layers
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 49152 bytes
Total number of registers available per block: 65536
Warp size: 32
Maximum number of threads per multiprocessor: 1024
Maximum number of threads per block: 1024
Max dimension size of a thread block (x,y,z): (1024, 1024, 64)
Max dimension size of a grid size (x,y,z): (2147483647, 65535, 65535)
Maximum memory pitch: 2147483647 bytes
Texture alignment: 512 bytes
Concurrent copy and kernel execution: Yes with 3 copy engine(s)
Run time limit on kernels: Yes
Integrated GPU sharing Host Memory: No
Support host page-locked memory mapping: Yes
Alignment requirement for Surfaces: Yes
Device has ECC support: Disabled
Device supports Unified Addressing (UVA): Yes
Device supports Compute Preemption: Yes
Supports Cooperative Kernel Launch: Yes
Supports MultiDevice Co-op Kernel Launch: Yes
Device PCI Domain ID / Bus ID / location ID: 0 / 28 / 0
Compute Mode:
< Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 10.1, CUDA Runtime Version = 10.1, NumDevs = 1
Result = PASS

Looks like the 10.1 run time is still loaded.
I did my best to read the install guide line by line, I’m getting back up to speed with Linux/Ubuntu. Apologies for my confusion.

Any advice?

Thanks again

After a restart and re make of deviceQuery 10.0 is now showing as my runtime version.


hi @hicksbc. have you got the CUDA Driver Version = 10.1 or CUDA Driver Version = 10.0 after restarting?